TurnKey Linux Virtual Appliance Library

Changing Trac date/time format [SOLVED]

Thomas Nilsson's picture

I have not been able to change the date/time format in Turnkey Trac from the default US format. The global locale in Ubuntu is set to sv_SE.UTF-8 but this seems to have no effect in Apache and Trac. The TK setup is a little different from my previous installations of Apache and Trac so I am confused about where to add a SetEnv variable (if that is the way to do it). Any help would be appreciated.

/Tom

Jeremy's picture

apache config file should be in /etc

Have a look at /etc/apache2/apache2.conf to be precise.

The Trac FAQ should help with the details of what needs changing.

Thomas Nilsson's picture

Adding this line in trac.wsgi

Adding this line in trac.wsgi solved the problem:

environ['trac.locale'] = 'sv_SE.UTF-8'

Thanks for pointing me in the right direction! :)

/Tom


Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)