TurnKey Linux Virtual Appliance Library

phpMyAdmin problem - PHP5-CGI

I installed mod_fcgid and mod_php5-cgi by these instructions (http://phphints.wordpress.com/2009/01/10/improving-php-performance-with-...). Now phpMyAdmin doesn't work: error 403 Forbidden. When I enable mod_php5 again, phpMyAdmin works. What I should do that phpMyAdmin works running PHP5 as CGI?
Liraz Siri's picture

Reconfigure phpMyAdmin...

phpMyAdmin is configured to use mod_php by default. The configuration is in /etc/phpmyadmin/apache.conf. If you insist on turning off mod_php on your server than you'll need to reconfigure phpmyadmin to use it, just like you configured your other application to use FCGI.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)