TurnKey Linux Virtual Appliance Library

Appliance Tomcat Stand Alone: How to change to MySQL Engine type INNODB by default

I faced something like these after modifying my.cnf:

110330 18:00:44 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use GCC atomic builtins
InnoDB: Error: log file ./ib_logfile0 is of different size 0 5242880 bytes
InnoDB: than specified in the .cnf file 0 262144000 bytes!
110330 18:00:45 [ERROR] Plugin 'InnoDB' init function returned error.
110330 18:00:45 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
110330 18:00:45 [Note] Event Scheduler: Loaded 0 events
110330 18:00:45 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.1.41-3ubuntu12.8'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu)

Can someone help me to solve this?

Jeremy's picture

I'm not sure

But have a look at this thread. It actually relates to the previous (v2009.x) TKL release but may still be relevant. Have a try and see if it works. Be great if you could report back, especially if you get it sorted.

Thanks Jeremy - The link helps.

Yes, apparently corrupted log file of some sort. Followed the scripts to remove the log file as shown in the link by the original poster and after that I re-created my database, and all the tables, populated them again, and well the innodb plugin is on. Except there were still some erros:

 

110331  1:50:05 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use GCC atomic builtins
110331  1:50:06  InnoDB: highest supported file format is Barracuda.
110331  1:50:06 InnoDB Plugin 1.0.5 started; log sequence number 347127
110331  1:50:06 [Note] Event Scheduler: Loaded 0 events
110331  1:50:06 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.1.41-3ubuntu12.8'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu)


Jeremy's picture

Check the setup in the MySQL config file

They don't seem to be errors, notes/info. But if you would to try getting rid of them have a look at the MySQL config file. You should find it at /etc/mysql/my.cnf

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)