TurnKey Linux Virtual Appliance Library

Lamp php throws HTTP ERROR 500

I recently updated my development Turnkey Lamp to continue my development. But now whenever there is an error in my php script instead of going through my error handlers helping me to debug it just throws a HTTP Error 500(Internal Server Error). It does this for anything, if I forget to put a ";" it will throw it out. What is the setting I need to alter? Thank you.

Change in

Change in php.ini:

display_errors = On

php debugging

I also had this error 500 trying to install phpBB_openid.

 

I installed the standard development php.ini from http://svn.php.net/repository/php/php-src/branches/PHP_5_3/php.ini-development and now there is no error but the install script just gives me a blank page with nothing on it. :(

Can someone suggest a good tool to use for debugging php on Turnkey Lamp stack?

Thanks in advance :)

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)