TurnKey Linux Virtual Appliance Library

Samba Shares - File Permissions

Hi Everyone,

I'm positive this has been answered a million times, but I don't know what I'm doing wrong. I've searched this forum and plenty of others, I just can't get this sorted and I need help!

Have a small network with TKL Fileserver.  5 clients access the samba shares.  I want 3 of them to have read only access, and the other 2 to have read write access.

I have set up the 5 linux accounts.  I've given them the same name and password that they use in Windows.  Converted the Unix accounts to Samba accounts.  Set up user and group synchronisation too.

I set the file permissions at 775.  I have added a new Linux group called write_access, and added the two accounts that I want to be able to write to the shares to that group. I also added the accounts to the read/write users in the security and access control menu.

I recursively set the owner of the directory to root, and the group to be the write_access group.

The read only accounts (there are 3) are in 2 groups - 1 in a group by itself, the other having 2.  there is a possibility that I'll have to maintain different access for these groups.

The read ony accounts work fine.  No problems at all.  I have restricted access to one of the read only users - they can only access some of the shares, and I did this by using the invalid users option.

Using one of the read/write accounts, I can't copy files to the share, or create new folders.  I get a "you need permission to perform this action" error.

If I change the owner of the directory recursively to the account that I am using, I am able to copy files to the share and delete. 

Shouldn't I be able to do this given that the account is in the write_access group and I have file and directory permissions at 775?

What am I missing? I've clearly got something out of whack, and it's got to the point where I am annoyed!

Cheers,

Smoe

Actually - it seemed to be

Actually - it seemed to be limited to only one directory that I created in my initial setup when I had logged on as root.

The weird part is that i had run a chown recursively, so everything was owned by the root user.  yet, being in the write access group i could change other directories and files that were owned by root - just not this particular directory.

I copied the directory into another directory (which had ownership of root:write_access) with no problems.  Went back and rm'd the problem directory via command line, and copied the backup to where i wanted it.  Now when I go in, I can read or write to my hearts content.  Weird as.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)