TurnKey Linux Virtual Appliance Library

Turnkey Linux refuses to keep a static ip address

I keep trying to set a static ip address on turnkey linux but it always eventually gets a new one from DHCP. What am I doing wrong? My router is pfSense. Any help would be greatly appreciated.

Also...

BTW: It does not have to reboot to get a new IP.


Jeremy's picture

Hmmm, very strange.

It certainly shouldn't be doing that! I assume you are using the confconsole to set your static IP? I have VMs that have had static IPs for months and it survives reboot as well. I can't think of anything that would be causing that behaviour, beyond not saving the static IP.

Oh, is that how you do it!

Actually, I did it from webmin. It seems to be working now! Thank you!


Jeremy's picture

Ahhh...

I didn't even consider that you may be doing it from Webmin. I suspect what was happening was that whilst you set it in Webmin, confconsole was still using DHCP so they were fighting. It looks like confconsole was winning! :)

IMO though this is a bug. Ideally if you set a static IP in Webmin, confconsole should honor that. I have logged a bug here, although TBH it probably won't be high on their agenda as it's easy to workaround as you've discovered.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)