TurnKey Linux Virtual Appliance Library

Migrating Wordpress database from another server?

Brian Padgett's picture

Hi,

First of all I love the Turnkey products. I am trying to use either the Wordpress Appliance or the LAMP Appliance to host my wordpress site. I have tried migrating my database manualy using instructions here and also BackupBuddy from here. I have not been able to get it to work successfully. I am actually migrating from Godaddy. Can anyone suggest the best method or better solution?

Thanks

frostbyte5014

Jeremy's picture

The instructions you link to should work

Just having a quick look over the (manual) instructions you link to should work. Although some of the import steps will probably not be required.

I haven't done it so you may need to make minor modifications.

To start with if you use the TKL WordPress appliance you shouldn't need to make a new database, just overwirte the default one with your data. I think TKL WordPres has phpMyAdmin installed so you should be able to use that to import your database. I don't think you'll need to change the WordPress config if you do it that way.

Give me a few more details regarding your problems/errors and perhaps I can help.

Brian Padgett's picture

I finally got it to work. My

I finally got it to work. My problem was that I needed to edit the write permisions. Took me a little while to figure out how to do that. Once I made those changes, BackupBuddy did it's magic. It is working great now. Now I'm looking for an email solution. May take a look at Zimbra. Wonder if an Open-Exchange appliance is in the near future?

Kind Regards,

frostbyte5014

Can you tell us how?

Hey Brian, I'm having the same problem, can you tell us exactly how you amended the permissions?

Jeremy's picture

phpMyAdmin is probably the easiest

Log in using your root password and IIRC you'll find it under "privileges".

Hmm, those are user privileges...

The error I am getting is when I navigate to the page that contains my wordpress files

 

Error #224834. This directory is not write enabled. Please verify write permissions to continue.

 

I am guessing I need to use chmod to change the permissions for the directory. Please forgive my ignorance but I am still learning! 

Jeremy's picture

Or chown

In fact I'd probably do both. First chown to the webserver user (www-data) then chmod to something like 755 and see how you go. That should solve your issues.

error 224834

OK so I am having the same issue I have opened all write privliages for the impiortbuddy file to 777 still getting same error

Jeremy's picture

Did you use -R switch?

To recursively apply permissions you need to use the -R switch.

Also FWIW IMO changing the ownership to www-data (the webserver user account) is probably better than setting 777 (read/write/execute for anyone).

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)