TurnKey Linux Virtual Appliance Library

lamp, "failed to get language list : java.security.AccessControlException ..."

Hello,

After installing LAMP into virtualbox on ubuntu 64 bit, and trying to start the file manager, using latest version of mozilla browser, i get a "failed to get language list : java.security.AccessControlException ..." error. Browsing the web, it was suggested to clear certificates, clear cache, but nothing helps. I even upgraded webmin to the latest version using the shell.

Interestingly, an own lamp installation on ubuntu 11.04 with webmin, the file manager works. So, i am not sure what the problem is.

 

Any help would be much appreciated.

Dan

Jeremy's picture

I haven't come across that one

But I recall when I first started using Webmin I had some problems with the java parts not working properly untill I installed sun-java-jre (rather than the open java that's installed by default). I also recall that the first time I used it there were a number of Java security warnings that had to be ticked and oked.

Java language List Failure

I have the same issue as Dan.  The File manager did initially load but now the error "Failed to get language list: javax.net.ssl.SSLHandshakeException..." has just shown. Have not done anything apart from re-starting the server.

Updated Webmin but no difference.  Running on a Mac and seem to have the latest Java JRe version.

Any ideas? 

Thanks,

John

What worked for me on ubuntu

What worked for me on ubuntu was to remove the non standard java package that came with ubuntu, and install original java package from sun/oracle. Possibly, the same might hold for osx.

Java Error

Thanks Dan.  Also on Ubuntu so will give that a try. - Rgds, John

Jeremy's picture

Just to clarify

The default java included in Ubuntu (and most other Linux distros) is an open source version (not sure who it's maintained by now but as far as I know Sun released it prior to the Oracle takeover). In my experience it works quite well for most things, but Webmin and the ProxmoxVE console are not 2 of them! The proprietry java supplied by Sun/Oracle (the Ubuntu package is called sun-java-jre and installed from the Ubuntu Partner repo - which is usually disabled by default) doesn't seem to have these same problems in general (although in my experience it does seem to chew a bit more RAM).

clear the Cache ....

Had the mentioned problem with Ubuntu server and Firefox on Mac OS. For mem the solution was to clear the Java Cache on my client machine. Java does not seem to trust itself ....  ;-))

indeed just clear the cache and... use an other broweser

If you use chrome, simply clea your Java cache and launch the file manager via an other browser

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)