TurnKey Linux Virtual Appliance Library

shutdown - poweroff

recently installed Turnkey Fileserver ( TurnKey Linux 11.1 / Ubuntu 10.04 Lucid LTS) on an old Intel 440lx mobo; i can't get the machine to power down after "shutdown -h now" or "shutdown -P now" 

the system will halt correctly but won't power off.   used to run another distro where this was not a problem. also tested same with an old copy of Knoppix 3 and it shuts down - powers off just fine! 

any suggestions of what i might try?

Halt but not power off

I have the same problem, but I'm using Turnkey Wordpress + VirtualBox. After shutdown the system halt but do not power down. Alter some minutes I have to kill VirtualBox process in order to get it down, and after restarting VirtualBox it show my VM as aborted. I think this may corrupt my VM if continues to happen.

This problem used to happen more times if Mouse Integration is enabled, but I don't know how to avoid it.

Jeremy's picture

Check that ACPI is installed

Although OTTOMH it should be. Also I'm sorry but i can't recall exactly what the package you'll need is. Sorry I can't be of any more specific help right now, I don't have access to a TKL appliance and I'm writing this in Windows (I just got a new laptop and haven't had a chance to install Linux yet!)

[update] actually I just checked on the manifest and it seems that acpid 1:2.0.7-1squeeze4 is installed so AFAIK that should do it, strange...

[update 2] Have you tried any of the other shutdown options?

poweroff

or

shutdown -h now

or

shutdown -h 0

Jeremy's picture

Found a fix!

I have recently started using TKL in a VBox VM on Win7 and the lack of graceful external shutdown has been causing me some pain too so I investigated a little more. As it turns out there is a package you need; it's called acpi-support. It pulls down about 18MB of dependancies but it works! Install like this:

apt-get update
apt-get install acpi-support

My VBox instance now happily shuts down when instructed to by VBox! :)

This requires fewer dependencies...

The above post seems will install x11 as a dependency :-(

This installs fewre dependencies:

apt-get install acpi-support-base

and now I can shutdown gracefully with VBox also.


Jeremy's picture

Don't think it did for me...

But I don't recall now...

Regardless, thanks for posting back. If that does the job, then that's great. 

Out of curiosity, are you using v11 or v12 TKL? In Ubuntu 10.04 (the basis of TKL v11) dependancies are handled a little differently ('recommended' are installed by default as well as 'required'). In Debian 6 (basis of TKL v12) only 'required' are iinstalled.

But maybe I just wasn't paying enough attention when I installed it! :)

...actually maybe just some x11 libs

Looks like I was mistaken. acpi-support doesn't install the full blown x11, but it does install a handful of x11 libraries. Regardless, acpi-support-base makes the TKL vm shutdown gracefully when virtualbox gives the acpi shutdown event and has fewer dependencies.

I'm using a TKL v12.

Best regards!


Hale's picture

You need only

You need only acpi-support-base

acpi-support-base 0.137-5 works well on TKL12 under VBOX 4.2.12

but not perfect. some weird failures are displayed just before poweroff.

It doesn't install any x11 libs, like full acpi-support do. I tried both and cleared acpi-support later


John Carver's picture

I've been having trouble

I've been having trouble shutting down ProxMox VM's running TurnKey 12.0 appliances.  Researching the problem eventually led me to this thread.  dpkg on all the VM's showed the following:

# dpkg -l acpi*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version        Description
+++-==============-==============-============================================
un  acpi-support-b <none>         (no description available)
ii  acpid          1:2.0.7-1squee Advanced Configuration and Power Interface e

After installing acpi-support-base as recommended above, I'm able to shutdown the ProxMox VMs without errors.  I found the same situation on the one 13.0 test appliance I had running.  I recommend that the acpi-support-base be added to version 13.x appliances.  It's probably not worth the effort to release new versions of 12.0 and 12.1, but everyone should be aware of the fix.

Information is free, knowledge is acquired, but wisdom is earned.

Jeremy's picture

I'm sure i lodged a feature request

IIRC I lodged that on the old TKL LaunchPad bugtracker (before the move to GitHub) but it isn't there on the TKL Dev Tracker... This makes me think that it should be installed by default in v12.1 (but I know it wasn't in v12.0). If you can confirm that it isn't installed on v12.1 then we need to lodge a new bug/feature request to include it...

Or better still someone could clone the Core source (on GitHub) and add it to the Core build code and submit a pull request...

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)