TurnKey Linux Virtual Appliance Library

MYSQL Setting update from WEBMIN not taking (Magento 11.2)

L. Arnold's picture

Just tried 3 times to set/reset:
query_cache_size:  from 16777216   to 268435456

query_cache_limit:   from   1048576  to 16777216

Whenever I restart MYSQL the Original settings return.

I have read that up to half of Memory available to a Magento Install should be allocated to MySQL and cache.  Running on ESXI and can provide from 1024 to 2056mb for the Application.

I must be missing something...

_________

Update:  Digging into my.cnf --  seems to be the place to set variables more permanently

references:  http://dev.mysql.com/doc/mysql/en/server-system-variables.html

-------- Seemed to Take, but perhaps I don't want such a high number on Limit.  Studying.

Why does not WEBMIN actually save changes of his sort?  I recall the same isse relative to setting InnoDB settings a year ago or so.

Jeremy's picture

Yep my.cnf is the place

But Webmin changes should stick permanently. Not sure why it doesn't!? Generally how Webmin works, is that it makes the changes to the relevant config files (it's just set out a little easier to understand rather than manually editing a file, you can click check boxes etc). So assuming you click the 'save' button (generally at the bottom of the page) it should permanently save the changes to the conf file.

Having said that I often don't use Webmin as I rather learn the intracies of manually configuring the conf files. There are a couple of exceptions, Samba being one of them. Anyway, I haven't used the MySQL Webmin module at all so can't really comment further.

If you are sure that you saved your changes in Webmin and it still didn't stick then I suspect that there is a bug somewhere...

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)