TurnKey Linux Virtual Appliance Library

ispCP installation

Hi everybody,

I've just started with Turnkey yesterday.  I'm trying to make my web developing server with Turnkey LAMP stack.  I've successfully downloaded the latest Turnkey LAMP stack VM and run it under VMWare Workstation on my notebook.  Everyting seems running fine.  I'm not good on Linux and so I appreciate that Turnkey is the easiest way I've ever seen to setup a web server.  Anyway, I want to go a bit further to install the ispCP (http://isp-control.net) to make it even easier to manage websites on my server.

I've searched this forum but didn't find any post mention ispCP.  Has anyone had experience with ispCP on Turnkey?

Thank you,

Tony.

Jeremy's picture

Looks interesting...

TKL v11.x is based on Ubuntu 10.04 so you can try following the instructions here. From a quick read over it though, perhaps you may be better off starting with Core? It may work fine on LAMP but it sounds like it pretty much configures everything from the ground up and is expecting a more-or-less clean slate. You may have less headaches starting with Core although who knows perhaps building on LAMP would be fine? Only one way to find out! :)

Before you start, I would put a hold on the udev package (so it doesn't update) because there is a bug with it which is a real pain. Here is the line of code to do that:

echo udev hold | dpkg --set-selections

The only thing that I can see at a glance that may confuse a Linux newb is at step 3, where it says:

You have to modify your sources.list. Edit /etc/apt/sources.list and change:

	deb http://archive.ubuntu.com/ubuntu lucid main restricted

to

	deb http://archive.ubuntu.com/ubuntu lucid main restricted multiverse

You will find the sources.list in /etc/apt/sources.list.d/sources.list instead, and in TKL each repo entry has it's own line with many of them commented out. To edit it from the commandline go like this:

nano /etc/apt/sources.list.d/sources.list

It looks like you need to enable the multiverse repo (and perhaps restricted too?) I don't recall if it's enabled by default so just look for the line that ends in 'multiverse' (and perhaps 'restricted'?) and remove the '#' from the start of the line(s).

If you hit any problems feel free to post back and I'll help as much as I can. You may need to consult the ispCP forums but it'd be great if you can post back here regardless as perhaps others will want to follow in your footsteps?

Thanks

Hi Jeremy.  Thank you very much for your quick and detailed advice.  I followed that instauction once and udev was exactly where it hung.  I've posted in the ispCP forum but so far no reply yet.  Let me try it again with your additional steps, I'll post the result here as it might be useful for the others.


Jeremy's picture

Yes that udev bug is a pain

It's actually an upstream (ie Ubuntu) bug, but as it only seems to occur with some hardware and with a specific set of software installed (which unfortunately the TKL images all have) it's not that common outside of TKL.

If you want to try to resolve it then have a look at this post. Otherwise just start again from scratch and put a hold on udev before you do anything else (the top line of code in my post above or the bottom line of code in the link in this paragraph).

And yeah, posting back here would be great! :)

On progress

Thanks Jeremy, your advice is super helpful to me.

I took a look and follow instruction on your other post and everything seems to work fine.  Now I'm changing the file "sources.list".

The problem is I don't see the line that says.

deb http://archive.ubuntu.com/ubuntu lucid main restricted

There're these 2 lines instead.

deb http://th.archive.ubuntu.com/ubuntu lucid main

deb http://th.archive.ubuntu.com/ubuntu lucid universe

So which line should I change?


Jeremy's picture

That's why I mentioned it in my first post above.

TKL sets out the sources.list file differently so it easier to only enable the repos that you need. If you look at the ispCP install instructions, they add 'multiverse' to the end of the line (which enables to multiverse repo). The (easiest) equivalent way of acheiving that in TKL is to remove the '#' from the start of the first line that ends in multiverse.

Ie I would change this:

# deb http://au.archive.ubuntu.com/ubuntu lucid multiverse

to this:

deb http://au.archive.ubuntu.com/ubuntu lucid multiverse

Your lines look a little different because you're using a different mirror. These lines come from my machine (which is using the Australian mirror - hence the 'au.')

If you have probs you may also need to uncomment the restricted repo too, but I'd try that first and see how you go.

Looking good

Thanks again, it looks good.  Now I'm at step 3 the last line.  Just want to note that it's a bit differect so I use:

cd /usr/local/ispcp/ispcp-omega-1.0.7/docs/Ubuntu

then

aptitude install $(cat ./ubuntu-packages-lucid)

instead of the original lines.

I also didn't use the "-cs" parameter coz it shows errors when I used it.

Other than that it seems to work.


Jeremy's picture

Nice work

That'd do it!

Almost

I've been figuring out how to access the ispCP control panel.  Finally I've checked Webmin and found it's quite strange.  The ispCP was configure with address ":80" instead of Any and the port was "Any" instead of 80.  So I changed it and restart Apache.

Then I access it via browser and see the error "An error occured! Please, contact your administrator!".

Still no joy but I think I'm very close to make it works.  Pls let me know if you have any idea how to fix this.


Jeremy's picture

When you were installing did all packages install ok?

Or did some of them give errors at all? That's what I'd be checking first. You won't do any harm reinstalling them (if they're already installed ok, it will just say something like "already at latest version").

Just guessing but I'd be looking for a package that needs to be installed but didn't or a mod that needs to be enabled but isn't.

Out of interest did you end up installing on Core or LAMP? If on LAMP then perhaps there's an issue with something that was disabled or enabled that needs to be the other way round...? That may possibly give some explanation of the weird behaviour you noted in Webmin (or not...?)

At the last step perhaps

I'm working with the Turnkey Lamp Stack.

I've installed many of required modules until (I think) the last step.

When I run command "perl ./ispcp-setup" and entered all required info I've got this error.

* ispCP Apache fastCGI modules configuration: [ Failed ]

Any advice?


Jeremy's picture

Check that fastCGI is installed

At the commandline run this:

apt-get install libapache2-mod-fastcgi

If it says something like "libapache2-mod-fastcgi is already at the latest version" then that wasn't it. We'll have to see if there's a log file that can give us some more info.

If OTOH it says that it's installing then run the script again and see if that works.

If you get a message saying something along the lines of that it can't be installed then perhaps try enabling the 'restricted' repo (like you did with 'multiverse'). (libapache2-mod-fastcgi is in multiverse, but perhaps it depends on something in restricted?) Then run:

apt-get update

Followed by the first line of code I gave above.

Let me know how you go.

One step closer!

Not sure if I update the sources.list file correct so I just list it here for you to check.

deb http://th.archive.ubuntu.com/ubuntu lucid main
deb http://th.archive.ubuntu.com/ubuntu lucid restricted
deb http://th.archive.ubuntu.com/ubuntu lucid multiverse
deb http://th.archive.ubuntu.com/ubuntu lucid-updates main
deb http://th.archive.ubuntu.com/ubuntu lucid-updates universe

I've commented out this line because it seems to show error when update

deb http://archive.turnkeylinux.org/ubuntu lucid main multiverse restricted

I've run "apt-get update" successfully after commented out the line above.

Now I get past the fastCGI error but there's another error:

*ispCP Courier-Authentication: [Failed]

I'll Google it and let  you know how it comes out.


Jeremy's picture

You shouldn't have needed to add or remove anything from sources

Except for removing the '#' from the start of the lines you wish to be active. I suggest your sources.list should look like this:

deb http://archive.turnkeylinux.org/ubuntu lucid main

deb http://th.archive.ubuntu.com/ubuntu lucid main
deb http://th.archive.ubuntu.com/ubuntu lucid universe
# deb http://th.archive.ubuntu.com/ubuntu lucid restricted
deb http://th.archive.ubuntu.com/ubuntu lucid multiverse

deb http://th.archive.ubuntu.com/ubuntu lucid-updates main
deb http://th.archive.ubuntu.com/ubuntu lucid-updates universe
# deb http://th.archive.ubuntu.com/ubuntu lucid-updates restricted
deb http://th.archive.ubuntu.com/ubuntu lucid-updates multiverse

# deb http://th.archive.ubuntu.com/ubuntu lucid-backports main
# deb http://th.archive.ubuntu.com/ubuntu lucid-backports universe
# deb http://th.archive.ubuntu.com/ubuntu lucid-backports restricted
# deb http://th.archive.ubuntu.com/ubuntu lucid-backports multiverse

Note the only change from standard TKL is the removing of the '#' from the lucid & lucid-updates multiverse repos (you probably don't need to enable lucid-updates but it wouldn't hurt IMO). As I said in my last post you may also need to enable the restricted repos ie remove the '#' from the start of the top 2 lines that end in 'restricted' - leaving the last 4 backports lines the ones to start with '#').

Did you run

apt-get install libapache2-mod-fastcgi

???? If so what was the outcome of that?

BTW TKL only supply a 'main' repo, that's why you were getting an error! So rather than comment the line out, just change the turnkey line back to default (as it is in the first line of the sources.list I posted above).

I've changed the sources.list

I've changed the sources.list as in your suggestion.

I've run "apt-get install libapache2-mod-fastcgi" once already.  I've done it again and it said "it's already the newest version.

So far I think I have no problem with the fastcgi anymore but with "

*ispCP Courier-Authentication: [Failed]

instead.

Now I'm going to re-make the ispCP and setup again.


Problem with Courier-Authentication still :-(

I've re-run this command again:

# apt-get install $(cat ./docs/Ubuntu/ubuntu-packages-lucid)

This time I see a message that it's going to install something Courier, so this might be it.  I'll let you know then.


One step closer but still error

Jeremy, I've start a clean installation for the Turnkey LAMP image but this time change the file sources.list as in your advice and the installation has run through without error.

Anyway when I try to access the ispCP control panel, I've got this error "An error occured! Please, contact your administrator!"  with ispCP Omega logo.

I've tested it further by changing the ispCP port to 81 then create a test virtual server and I found that my browser can load "index.txt" correctly but shows error message when I try with "index.php".

So I think there must be something wrong with the PHP extension.

Any advice?


Jeremy's picture

Running out of ideas...

I think you'll need to search through your logs to see if they give any hints. That error message isn't very helpful. Logs are all generally found in /var/log/  the apache one would probably be worth a look for starters. Its probably also worth consulting the ispCP forums/wiki as perhaps this is a common or known issue? Perhaps they have some ideas as where is a good place to start troubleshooting this one!?

Strange

I've found out that after this command

apt-get install $(cat ./docs/Ubuntu/ubuntu-packages-lucid)

PHP seems to stop working.  I've created a virtual web server and successfully testing it after every steps.  Just after the command above then my browser tried to download my PHP script (index.php) instead of displaying the content (phpinfo()).

At the same time a text file (index.txt) works correctly on my virtual web server so I assume that Apache has no problem.

I'll continue testing each module in the packages file but there're so many, any advice would be appreciated, please :-)


Jeremy's picture

As you may have guessed...

The 'apt-get' command is a package managment commandline app. And used with the 'install' option installs packages from the repos (as defined in the sources.list file). aptitude is a somewhat similar commandline app.

My suspicion is that either there is some interactive config that needs to be done during the installation process that somehow is getting skipped (and thus not being configured properly). Or something from the default TKL LAMP config is upsetting ispCP somehow.

To troubleshoot the first possibility you could install the packages one-by-one (as it sounds like you are planning to try) and/or check the apt-logs (something like /var/log/apt or similar - have a look at ls /var/log and see if there is a file/folder called apt or apt.log).

Have you tried posting in the ispCP forums to see if they can be of any help? TKL is based on Ubuntu 10.04 (which the install script should theoretically work with apparently). Even if they can't help you exactly (the error is pretty vague), I'd like to think that they could at least help you with where to start troubleshooting. Serously, the "An error occured! Please, contact your administrator!" error message is pretty useless IMO, especially when you ARE the administrator! Maybe there is some sort of debug mode that you can enable to allow a more useful error message?

Another thought... Have you set a FQDN (fully qualified domain name) for your server? I'm only guessing but perhaps that is a requirement of this software? Most scenarios where you would be using this sort of software possibly assume that you have already set this? You can add your FQDN to the /etc/hosts file. You'll also need to add an entry to the hosts file of the desktop PC you are working from (at least temporarily until you have a proper domain name and DNS/nameserver propagation setup for it).

So short of trying to install this software myself (and possibly running into the same issue) I really can't give you much more than I already have!

One final thing to consider is, is there a reason why you specifically want ispCP? There are many free and open source Linux control panels around (although no doubt some better than others). At least some of which shouldn't cause this level of frustration installing... Just a thought... ISPConfig looks pretty nice although I can't vouch for it's ease of installation (I've never tried installing/using it). Virtualmin gets plenty of positive reviews and is probably what I'd be inclined to have a crack at myself where I to be looking for a hosting panel. It has a (free) open source version based on Webmin (which is preinstalled in TKL) which may (or may not) provide a start... Perhaps food for thought if you can't figure out ispCP...

GOt the infamous fast-cgi error as well

I am on mint/ubuntu and dumping efforts to install ispCP - now it is complaining (in the error log that I do not have PHP4 - have PHP5 installed) - just got fedup after 4+ to get the installation going....

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)