TurnKey Linux Virtual Appliance Library

Read only appliance

Ok, i was going to write some code so i boot up the symfony appliance just like always but when i started to execute some code to the database i got "Mysqli statement execute error : Table 'articles' is read only". Then, when i tried to uplaod an image from a form i got "The given destination is not writeable". So, what's going on? All the system appears to be in read only mode !!

 

Thanks for reading,

Fernando.

Jeremy's picture

This behaviour is normally caused by file system errors

If TKL is running inside a VM then the physical hard drive that the virtual filesystem resides on is also worth checking (using filesystem tools of the native OS). Sorry I haven't got time to explain more clearly step by step for you ATM but there is at least one other topic here that deals with this issue. Give you a hint for starters - you will need to boot with a Live CD (or ISO if running virtually) to be able to check the filesystem.

I tried to fix the filesystem

I tried to fix the filesystem booting from a LiveCD with fsck -y but nothing changes.

Jeremy's picture

Did it find errors?

Did you fsck the PV (phyiscal volume - LVM) as well as the LV (logical volume)?

And as I said if it's a VM you may also need to do a chkdsk (assuming it's Windows) on the physical HDD. Personally I'd check the physical drive first, then the PV and finally the LV.

There's a few threads that may be of interest; here, here and your old thread here.

Speaking of your old thread is this a new problem or just trying some more to fix the old VM? If this is a new issue then I'd be looking carefully at the physical HDD. Unless these issues relate to 'dirty' shutdowns (ie not shutting down properly) then having this same (/similar) issue again would suggest to me that there is definately something wrong with physical storage.

Jeremy, thanks for your help!

Jeremy, thanks for your help! Is a new issue so now i'm testing a new VM on another partition to see what happens.

 

Fer.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)