TurnKey Linux Virtual Appliance Library

Idiot guide to file server?

I was wondering if there was a good guide to setting up the file server, one which deals with configuring users and shares?  I've been fighting with TKL file server, to no avail.  My end goal is three separate shares, each accessable by different user groups (I'd prefer to manage at the level of groups, if at all possible, as some users may be in multiple groups).

The TLK is virtualized under virtualbox, with four folders shared which I want the TKL to use as the server storage.  All four of these appear in the /media folder, so I know they're mounted in a way TLK can access them.

I used the webadmin to first set the samba server name and workgroup, and then set the various folders as separate shares, and at the same time I removed the default shares.  I then went and created linux groups (after setting things up to auto-sync linux and samba groups/users); three groups in total.  I then created users, assigning to each user the appropriate group(s).  I then went back to the shares and set them to be read/write accessable to the groups I wanted access to each share.

AFAIK, that should work.  However, I am unable to see the shares on the network, nor can I map the drive directly via "Add Network Drive" in windows or via the "Connect to Server" dialoug in linux.  If I use the later I can sign in, but no shares/files are visable.

Any help - or an idiots guide - would be greatly appreciated!

Bryan

Jeremy's picture

What about Linux file permissions?

Have the users got access to the files/folders?

Others have had issues with the setup too and really it needs some better documentation. IIRC I struggled with this when I set up my TKL Fileserver (a few years ago now), but got there in the end...

I would also double check user sync (between Linux & Samba) because I found the auto-sync a little flakey in the legacy version of TKL (v11.x may be better but not sure...).

Bottom line is though that TKL v11.x is built on Ubuntu 10.04 so any of the Ubuntu docs regarding Samba should apply (although it won't explain how to use Webmin - just commandline).

I think I know what is wrong

I think I know what is going on.  I can connect via sftp, and when I do so I gain access to the root of the VM.  I can browse around on anything within the VM itself, but the folders I've linked to on the host (using virtualbox's guest additions) are not accessable - I get a "you do not have permission" error.

Thing is, the UID I sftp'd in with is one which should have access to those folders (I've checked, and the user is listed as having read/write access) which thinks the problem lies on the host side of things.

If anyone knows a good way to fix this, I'd like to hear.  I may just have to setup the folders on the host using samba, which seems a pretty round-about way of doing it.

Bryan


edumax64's picture

Fileserver Appliance.

Hi Brian, I agree with what you wrote in the post. I downloaded the ISO of the Appliance file server, and created a KVM virtual machine on ProxmoxVE. Works well I have access via sftp, but I can smb shares and to create ne'm Noj find traces of samba installed. I tried to install the modules for webmin samba, but we need the next version and updated. How do I create shares? The firewall and 'set to Accept. From the command line I can not install on Ubuntu SMB packets. You have no idea about, 'cause this appliance and' a really nice program! Thanks to everyone for their work.
Best Regards!

Jeremy's picture

samba & webmin-samba should already be there

So I'm not really sure whats going on there for you?

PS if you're using Proxmox, check out the new OVZ appliance templates (and TKL channel).

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)