TurnKey Linux Virtual Appliance Library

After launching Vtiger appliance backup to EC2, user is redirected to install.php

I'm have launched my Vtiger appliance backup to EC3 using the TKL Hub. It appears to have restored the backup and launched just fine. I can SSH to it, access the Webmin page and all that. But when I try to login to Vtiger, I am redirected to /install.php which results in "Forbidden: You don't have permission to access /install.php on this server." I reviewed ownership and permissions and the vtiger root folder is exactly like the original. Does anyone have any ideas?

Jeremy's picture

Sorry for slow reply...

Did you get this worked out? I don't have any idea what the problem might be.

I would assume that it's caused by a file that has been restored which shouldn't have been, or a file that should have been and wasn't. Some webapps use some sort of install.lock file so that you aren't redirected to install (and when the file doesn't exist you are), perhaps that file wasn't backed up. I suspect that may be what is going on. You could also try comparing the Prestashop config file (whereever that is) with a fresh instance.

But seeing as I don't know a lot about Prestashop I can't help much more than that. Perhaps the Prestashop forums might have some idea?

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)