TurnKey Linux Virtual Appliance Library

VirtualHosts Not Working with LAMP stack

ClickSlide Admin's picture

Hello,

I have my LAMP stack running on Oracle's VirtualBox. I followed the instructions here: http://doxfer.com/Webmin/ApacheWebserver#Creating_a_new_virtual_host

to setup my virtualhost "http://clickslide.loc" but the only thing I get is an error message. The message in Google Chrome is:

 

This webpage is not available

The connection to clickslide.loc was interrupted.

Error 101 (net::ERR_CONNECTION_RESET): The connection was reset.
 
I don't understand why this is happening, based on those instructions shouldn't the VirtualHost be working?
I'm running this on Windows 7 professional, on a Dell with intel i7 chip.
Please advise.
Jeremy's picture

Was it working via IP?

The first thing to do would be to make sure that it works via IP first. That way you know that the server is working correctly and networking isn't an issue. If you didn't check this initially then probably the first thing to do is revert back to standard TKL Apache config (you did a backup of the original file right!? Or better still created a new one!?)

Once you have confirmed that works. Then you can troubleshoot DNS to make sure that that is setup correctly. Querying your DNS with nslookup is probably ideal, but even a simple ping should do the trick (ie you want to make sure that the FQDN resolves to the correct IP).

Once you have confirmed all that (and have resolved any errors/issues), then you can troubleshoot Apache config.

The other thing to keep in mind is that unless you plan to host multiple domains, if the networking is all good and the DNS is configured correctly then it should work OOTB (without changing any Apache config). You only need to add extra/alternative virtual hosts if you want subdomains or multiple domains hosted on the same server.

ClickSlide Admin's picture

Thanks

Hi Jeremy,

Sorry about that, I got it working. I had the wrong IP address in my Windows (guest) host file. 

Thanks

aaron

-- 

ClickSlide

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)