TurnKey Linux Virtual Appliance Library

External drive not visible to TKL appliance

Hi,

Maybe I posted this under the wrong thread name so I'll rephrase my question.

I'm running a couple of TKL appliances in the Proxmox VE 2.0 (installed on an HP Proliant microserver). I mounted an external drive by accessing as root to the Proxmox host via ssh. Everything seems to be fine there and I can see all the folders in the mounted drive doing 'ls' from the terminal.

I'm at a loss as to how to manage this external drive via the Proxmox GUI. The external drive doesn't show up in any of the nodes. I admit this is a question that should be answered in the Proxmox forums but just in case somebody here knows.

That's not the most important thing, though. Basically what I want is to be able to connect to this external drive from the different TKL appliances I have installed in the VE. When I get into the appliances I have no way of seeing the external drive. When I use VirtualBox I am always able to connect to the external drives from any of the VMs. With appliances in the Proxmox VE, though, I don't see how one can do this. I would really appreciate it if someone could lend me a hand. Thanks in advance for your help.

JM

Jeremy's picture

Not sure about v2

In v1.x you had to add the storage from within the WebUI (from the 'storage' link) before you could do anything with it from within the UI. I know that there have been some significant changes on how this is handled behind the scenes in v2 and obviously the UI is completely different too. For v1.x there was extensive documentation on the wiki although I suspect that v2 docs are still work in progress.

So the short answer is sorry I have no idea (I am still running v1.9 and have had very little experience with v2 (although I did have a brief play with beta2).

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)