TurnKey Linux Virtual Appliance Library

unable to update Wordpress ftp/ftps error

Hi

 

I have downloaded wamp stack from this website and installed wordpress. When i try to update the plugins wordpress is asking for

1) Hostname

2) Username

3) password

 

and gave option button for ftp and ftps

 

Can someone tell me what goes in these.....I guess username will be root and password will be what I first setup. But giving hostname "localhost" is not working. it says "Failed to connect to FTP Server 192.168.1.5:21"

Kindly help

 

BIZW

Jeremy's picture

Firstly, you wouldn't download WAMP here...

Although you may have downloaded LAMP (the W in WAMP is for Windows - L is for Linux).

Secondly, if you want WordPress why not just start with the WordPress apliance?

If you want to persevere with your current custom WP on TKL LAMP then have a search of the forums, IIRC this issue was answered/resolved some time ago although I don't remember what it was...

Thank you Jeremy

I have now used wordpress appliance to make things easier but wish someone could tell me the solution......

Robert's picture

I just use the IP as Hostname

I just use the IP as Hostname when I setup scripts like this.

Hostname: 192.168.1.5 without the :21.

Hope that helps.


Permission Issue

Login through SSH and run this command

chown -R www-data:www-data /var/www

Im guessing you installed Wordpress using FTP, that means Apache does not own the files and or directories thus not letting it write to them.  Hope this helps.

Thanks!

Thanks a lot Lance.

I have been searching for this problem.

I never imagined it could be this simple!

Thanks a lot!

Thank you Lance

Thank you!  

Did not install WP

I had this same issue with an out-of-the-box WP TKL VM. Logged in as root, could not update WP. Lance's suggestion to explicitely provide access to the WP folders did the trick and the upgrade went through.

not root of course

but wp-admin. spam filter would not let me edit the previous post.

Jeremy's picture

FWIW

Glad to hear you got it sorted, but FWIW a better way to go is noted on the TKL tracker on GitHub here.

Also FWIW all future version of TKL WP appliance will include this adjustment so everything should be easier OOTB.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)