TurnKey Linux Virtual Appliance Library

Setting httpd.conf for Joomla16 server

I rebooted my Joomla16 server but it did not fully come back up.  I could connect to it using putty but not thru the Hub. Apache was saying it could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName.

Someone suggested I enter localhost for the ServerName in httpd.conf and that thankfully worked.

Many times when I try to spawn a server from a backup I get a similar problem where apache doesn't run correctly. Hopefully, this will solve the problem going forward.

My question, however, is this perhaps something in the hub or images that could be fixed there instead? Or, maybe a problem in the Hub setup I need to fix?

Thanks!

Jeremy's picture

That is only an Apache warning

I have had servers running reliably for years contantly giving that warning so that is not your problem. I'd be checking the Apache logs to see if there is somethjng else which is causing your problems.

Also FYI as a general rule it is 'best practice' (AFAIK) to configure Apache via apache2.conf on Debian & Ubuntu systems (not that it really matters as httpd.conf is still parsed - just that Debian & Ubuntu default config of Apache is a little different to other Linux systems).

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)