TurnKey Linux Virtual Appliance Library

Postfix virtual mail permission denied

 

I have just setup postfix and I can get it to send email to my gmail account via telnet, however when I try to send mail to a local account it fails to create the local mailbox. I increased to verbose logging and saw this error:
 
warning: table virtual_mailbox_maps: lookup webmaster@<mydomainname>.com: Permission denied
 
but I can run this with no permission problems, which is the query in the file mysql_virtual_mailbox_maps.cf
 
mysql --user=postfix --password=mydbpassword --database=postfix --host=localhost -e 'SELECT maildir FROM mailbox WHERE username="webmaster@<mydomainname>.com" and active = 1;'
 
The result from the query in mysql_virtual_alias_domain_mailbox_maps.cf also runs but returns 0 results which is correct. I believe postfix should throw a virtual_mail_box = proxy:path_to_file Permission denied error if file permissions were a problem, also the files and folder are owned by postfix with 770 permissions. 
 
If postfix can't get the name of the maildir it can't create it, I just can't find any info out there on why? There must be someone out there with the same issue, I just need to find the right post! Anyone have any clues? 
 
TIA

Found the answer

I started this series of posts here, and finished it off there to http://sourceforge.net/projects/postfixadmin/forums/forum/676076/topic/5331616

Jeremy's picture

Thanks for posting back

Thanks for posting back

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)