TurnKey Linux Virtual Appliance Library

Change port number for mediawiki

I've set up the mediawiki appliance and it works over the default port 80. However, if I change the port of the virtual server to something else (e.g. 8080), the browser gets no response.

Have I missed something? Do I need to change anything else?

Thanks,

Julian

Jeremy's picture

Have you told Apache to listen on 8080?

Have a look at /etc/apache2/ports.conf

I looked at the ports.conf

I looked at the ports.conf file using the Apache web admin Global Configuration tab and added Listen 8080 after the Listen 80 line. It works!

It would be helpful if changing the Virtual Server port through the web interface did this automatically, but I guess there may be reasons that wouldn't work.

Thanks for the solution.

Julian

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)