TurnKey Linux Virtual Appliance Library
Alon Swartz's picture

It depends...

If you set the hostname after the instance was deployed, then you can just release it in your account profile and allocate a new one on the server record.

But if you set it on the launch page, then it was preconfigured on the server itself, in which case you should make the change on the server itself. Log in via ssh/webshell and do the following:

hubdns-info                      # will display the current configuration
hubdns-release                   # will release the currently associated hostname
hubdns-force --force APIKEY FQDN # will re-initialize for new FQDN
hubdns-init --force APIKEY FQDN  # will re-initialize for new FQDN
hubdns-info                      # verify the current configuration

Hope the above helps...

custom domains?

What about with custom domains?  I got the following:

 

hubdns-release #                                                                                  
error: Request not supported: Not a TKLAPP.com FQDN

Not updating

Ok so I was unable to run hubdns-release, but I could remove the entry from the tkl hub domain management page.  I'm assuming that accomlishes the same thing.

 

hubdns-force --force APIKEY FQDN

 

should actaully be I think, right?

 

hubdns-init --force APIKEY FQDN

Then a hubdns-info confirms that my desired dns entry is pointing at my machine.

 

However my hostname does not seem to be resolving (it was resolving fine earlier when I put a manual dns entry in mapping my hostname to the current IP but I think that wouldn't update when the IP changes.

I also had an elastic ip associated with the instance, so I'm not sure how that would have affected hubdns.  

Any advice?

Alon Swartz's picture

Local caching or propagation issues?

Oops, sorry about the typo - yes, I meant hubdns-init (fixed in my original comment).

You're correct, you can only release a tklapp.com hostname - custom domains can't be released, as there really is nothing to release - thats just a feature of tklapp.com.

As to why it's not resolving, my guess is either local caching or propagation latency. What DNS servers are you using? I recommend using Googles 8.8.8.8 and 8.8.4.4 as they are super fast and comply with DNS TTL's correctly (unlike some ISP's DNS servers I've come across).

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)