TurnKey Linux Virtual Appliance Library

tklbam-backup error

Hi All,

our tklbam-backup in the hub gives out an error (see below).

It worked perfectly before and we didn't changed anything on the configuration.

So I have no clue what to do to get it work again!

Thanks for your Help!

> tklbam-backup
CREATING /TKLBAM 
Traceback (most recent call last): 
File "/usr/bin/tklbam-backup", line 266, in <module> 
main() 
File "/usr/bin/tklbam-backup", line 237, in main 
b = backup.Backup(conf) 
File "/usr/lib/tklbam/backup.py", line 267, in __init__ 
for fpath in fpaths ]) 
OSError: [Errno 2] No such file or directory: '/var/www/cache/data_search_results_ce2f33a68a81b9ee0aa8027c8d72d9fd.php' 

Alon Swartz's picture

use an override

You most likely don't want or need to backup cached files (the error is probably caused by a race-condition), so you should configure a TKLBAM override to ignore /var/www/cache.

Something like this should work:

echo -/var/www/cache >> /etc/tklbam/overrides

Out of interest, what appliance are you using? The default TKLBAM profiles shouldn't include cached files by default...

appliance

its the wordpress-11.3-lucid-x86 standard appliance!?

It wasn't in the overrrides file, but the backup worked without any problems until friday?!

However it works again!

Thanks for your Help, Alon!!

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)