TurnKey Linux Virtual Appliance Library

eth1 and eth2 in VM Aps

L. Arnold's picture

This morning I cloned a Turnkey VM and it went no problem.  Networking was set up to eth1, I assigned an IP and all was peachy.

I went through the same process aftr that cloning the new machine to a new third machine.  All seemed to go well, but when I start the VM it is looking for ETH2 rather than ETH1.  As such I can't log into it though I can kill the Console interface and root around there.

Why is this one looking for Networking on eth2 rather than eth1?  I only have one Network Interface defined for the VM (and the same for the other VM's)

(Am using ESXI 4 with the VServer setup to clone the VM)

Duplicate MAC addresses

Hello,

 

check out these posts, sounds like a problem with duplicate mac addresses:

http://www.cyberciti.biz/tips/vmware-linux-lost-eth0-after-cloning-image.html

http://lonesysadmin.net/2011/11/01/why-does-my-linux-vms-virtual-nic-show-up-as-eth1/

http://www.liberidu.com/blog/2006/09/29/solving-vmware-network-problems-on-linux-vmware-guests/

They are mainly for CentOS/Red Hat and Suse but I guess the fix on TKL should be similar or they should at least point you in the right direction.

 

Hope this helps,

Andy

Did another short search and

Did another short search and came across this problem in the vmware community:

http://communities.vmware.com//thread/198298?tstart=0

They also posted a fix for Ubuntu which should be the one you are looking for (Post #3 and #5).


Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)