TurnKey Linux Virtual Appliance Library

Apache 100% CPU load with TKL WP on VMware

Hi,

I've set up the TKL WP virtual appliance on VMware and put about 15 pages online in Wordpress. There is no traffic on that site yet as it's currently in development and still blocked by a firewall in front from being accessed.

Sometimes performance is just fine, but very often I see apache going to 100% cpu load, no matter what is being accessed (wordpress site, phpmyadmin, webmin).

Except setting an IP address there are no changes yet made on OS level and I doubt it has anything to do with the WP content and plug-ins I added as the issue also shows up with phpmyadmin or webmin.

First thought was a VMware host issue but I moved the VM to another host where it shows the same issue. In addition, all other VMs (Windows and Linux based ones) running on the same hosts have no performance issues at all.

Currently I'm pretty much stuck as I am not sure where and what to troubleshoot within apache to get closer to the root cause.

Anyone with better apache know-how here to give me a hint how to diag what's causing the high apache load?

Thanks

Tim

Jeremy's picture

Not much help...

But you are not the first to mention an issue like this with the TKL WP appliance. However many others don't have this issue (One guy has 2 WP appliances running, same version, one exhibits this behaviour and one doesn't). So I can only think that it is something that is to do with something you have done and/or some of the content that Apache is loading.

Obviously I'm not much help, but troubleshooting via disabling your content, piece by piece may be the only way to go with this issue...

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)