TurnKey Linux Virtual Appliance Library

I broke my phpmyadmin link

I installed Virtualmin on my fresh but old Ubu-LAMP 11.3 server but it broke the link on the index.php page.   It works from http(s):/IP-dom/phpmyadmin but not with :12322.  Not a big deal but thought I'd ask how to troubleshoot.  I created a fresh symlink but no go.  

I also would like to rename index.php to tkl.php so I can free up the root of /var/www for sites.

Not sure how to do that w/o breaking that too. ;)

Jeremy's picture

Renaming index.php should be fine

Renaming it to tkl.php shouldn't create any issues.

As for phpMyAdmin, I suspect that it has altered the TKL default virtual host (and replaced it with the default default one).

In a vanilla TKL appliance there should be a symlink in /etc/apache2/sites-available (called phpmyadmin) which points to /etc/phpmyadmin/apache.conf

And the /etc/phpmyadmin/apache.conf file looks like this:<VirtualHost *:12322>

<VirtualHost *:12322>
    SSLEngine on
    SSLCertificateFile /etc/ssl/certs/cert.pem
    ServerAdmin webmaster@localhost
    DocumentRoot /usr/share/phpmyadmin/
</VirtualHost>

<Directory /usr/share/phpmyadmin>
    Options Indexes FollowSymLinks
    DirectoryIndex index.php

    <Files setup.php>
        Deny from all
    </Files>

    <IfModule mod_php5.c>
        AddType application/x-httpd-php .php
        php_flag magic_quotes_gpc Off
        php_flag track_vars On
        php_flag register_globals Off
        php_value include_path .
    </IfModule>

</Directory>

Hopefully that'll get you going...

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)