TurnKey Linux Virtual Appliance Library

Bug in 12320 : can't use slash and :

Hi,

 

I tried to connect and to use the shell on 12320 port on my server but I can't use : or /.

Is it a bug ? It was working before...

Thanks for ideas,

Regards,

Sébastien.

Jeremy's picture

Have you updated or changed Java?

IIRC WebShell requires Java on the client system (ie the PC with the browser that you are connecting from). Perhaps try clearing the Java cache (I don't remember how to do it...)?

How about trying from a different browser? And/or try clearing cache and cookies.

Personally I don't usually use WebShell (I prefer using SSH) but I just tested using Chromium browser with IcedTea7 (ie open source Java 7) plugin on Bodhi Linux v2.1 (Ubuntu 12.04 based) and it seems to work fine for me (for what that's worth...)

Only with Iceweasel...

I tried with Chromium and it's fine. The problem is only with Iceweasel.

I use Debian and it was ok two weeks ago with Iceweasel.

I think I will disactive WebShell and use Putty to connect.

Thank you a lot !!!

Regards,

Sébastien.

Jeremy's picture

If you are using Debian

Then you don't need PuTTY, you can connect straight from your local terminal like this:

ssh root@<appliance-ip>

Bug in 12320: can't use - or _

dash and underscore just stopped working and not sure what changed.  I'm using an XP box with Firefox 15.0.1.  I tried clearing both cache and cookies, but still doesn't work.... Just checked - all 5 computers here running Firefox will not recognize "-" or "_", but several versions of IE will.  Putty works just fine.  Any ideas on what happened to Firefox?


Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)