TurnKey Linux Virtual Appliance Library

Moodle 2.3 TKL 12 clients > mixed content message after TKLBAM migration

I recently started the move from Moodle 1.9 to 2.3  Per my standard practice I built my proto-type using the TKL 12- Moodle iso in a virtual machine.    I then backed it up with TKLBAM and restored it to a new physical machine.    Everything seemed to go fine except --  clients are getting a mixed content message "contains both secure and nonsecure items"    I wondered if anyone has encountered anything like this?

To trouble shoot I am looking at:

1) restored differant server certificates - regenerate server certs

2) apache is trying to access content > curl and I need to install new cacert.pem in php.ini

3) reconfigure apache sites to use only ssl

 

Any sugguestion as to solutions or ideas as to where to start would be appreciated.

Thanks for your attention to this matter.

GP

 

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)