TurnKey Linux Virtual Appliance Library

Fileserver appliance cannot change upload max filesize

Hello there,

I downloaded the latest Fileserver appliance the other day (September 12, 2012) and installed it.  When I try uploading files using the Ajaxplorer, the small upload window shows an upload limit of 16 M.

1) I have tried editing /etc/php5/cgi/php.ini, changing the post_max_size and upload_max_size values.  Doesn't work.

2) I read the documentation on Ajaxplorer and it tells me that it is not a limit imposed by it but PHP.

3) I have edited _every_ file with the name php.ini in it and still nothing.

 

Please help!  Thank you very much!

Alex Lee

The php.ini file values that effect uploads are:

   
    file_uploads
    upload_max_filesize
    max_input_time
    memory_limit
    max_execution_time
    post_max_size

I usually set post_max_size to twice the value of upload_max_filesize.
Generally speaking, memory_limit should be larger than post_max_size.

The apache webserver has a LimitRequestBody configuration directive that
restricts the size of all POST data regardless of the web scripting language
in use

GP
 

Jeremy's picture

Apache needs to be restarted for settings to take effect

service apache2 restart

or

/etc/init.d/apache restart

[edited due to mistake suggesting to restart Apache when TKL File Server appliance uses LigHTTPd]

service lighttpd restart

or

/etc/init.d/lighttpd restart

still having issues

I've followed the recommendation to change php.ini, I upped the related limits to 128M, still no luck. Also, current version of the Turnkey fileserver runs lighttpd server, not apache.

I restart with " /etc/init.d/lighttpd restart"

after restart, I still get the "The file is too big" error. Any ideas? My users just need to upload pdf files around 10 to 20 meg.

 

I'm at a loss. 

had the same problem

and the solution was:

 

first: do all the modifications in the php.ini file suggested and restart the daeon,

And then there is another option in the web frontend configuration panel:

using your admin user:

go to Settings / Common uploaders plugin options / Limitations / File Size.

I still cant change the file size limit

Some of the instructions here are not clear.  I have version 12, i edited the file upload size in the php.ini file, but I cannot find the described area:

 

go to Settings / Common uploaders plugin options / Limitations / File Size.

 

Is this in Webmin?  I am loggin into webmin as root.

 

Thanks

Jeremy's picture

I assume that it's in Ajaxplorer itself

What leads me to think that is the mention of the 'admin' user account (as opposed to Drew's mention of the Samba root user).

Webmin does not have a user account called 'admin' (although I guess someone might call the 'root' account the admin account...!?) but I haven't seen that option in Webmin before either (and it sounds like you can't find it...)

So try logging in to Ajaxplorer as 'admin' with the password that you set on firstboot (or in the Hub if you are running this on AWS). If you are running as an OVZ container then you'll need to run 'turnkey-init' to set passwords if you haven't already (I think this applies to Xen and OpenStack images too).

Thanks, Jeremy and Sigi

and BOOM, that fixed it! I've been logging in as the root samba user, not the local admin, so I hadn't even seen those options.

Jeremy's picture

Nice work guys!

Good bit of documentation right there! :)

Jeremy's picture

Using the info from this forum thread I have created a wiki page

Here. Be great if any/all of you guys could check it out and correct it if I've got anything wrong... Thanks! :)

Changing php.ini

oooook... but, I have a quick question... Where is Ajaxplorer ?

Jeremy's picture

Ajaxplorer is the WebUI

It is the web app available by browsing (with a web browser) direct to your Fileserver. It provides the WebUI for up/downloading files. Sounds like perhaps that needs to be clearer...

Ajaxplorer is the WebUI

Yes... even thou, I dont know what is the WebUI... Where Can I fint it?... How can I get it?... Any tutorial for this?...

Thanks in advance...

Marco

Jeremy's picture

Open a web browser

on a PC that has a network connection to your fileserver appliance and in the address bar type the IP or FQDN of you appliance.

Upgrade

Hi there!

 I want to upgrade new version 5.0 from http://ajaxplorer.info/. How about do it?

Jeremy's picture

Check on their site

Perhaps their forums and/or wiki and/or other documentation (see this post I just did but think 'AjaXplorer' when I say 'osCommerce').

Works Fine

Hey, this information works great "http://www.turnkeylinux.org/node/4708" I set sam to this

 

file_uploads
upload_max_filesize =512M
max_input_time
memory_limit = 1024M
max_execution_time
post_max_size = 512M

And works very great, I think expand Memory ram to upload more large files.

I have a question, Went a "Drop" files, works fine, but when Y "Drop folders" i AjaExplorer Say "Sorry you can drop folders, only files" there is a posibility to enable "Drop folders in AjaExplorer"?

thanks a Lot for the answers (for my question)

PS: I hope to contribute with this project that I find wonderful

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)