TurnKey Linux Virtual Appliance Library

Hub Server not using /dev/xvda2 for /tmp

I deployed a LAMP Debian 12 server to the turnkey hub, and whenever I run database operations (REPAIR TABLE) on our 12gb+ database I am getting errors about running out of space.

I have tried to bind the /tmp directory to the 350gb tmp directory that's included with the server, but it keeps filling up my main 20gb disk. I don't know if I'm doing it wrong, if I need to restart the server, or if there's some other step I'm missing.

What can I do to ensure that the server is writing all it's tmp data to the /dev/xvda2 instead of /dev/xvda1?

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)