TurnKey Linux Virtual Appliance Library

Issue with setting up SSL on website

I followed the instructions here: http://www.turnkeylinux.org/blog/ssl-certificates

I doubled checked everything, it seems like it should be working. However whenever I type in a https:// URL, it immediatly redirects back to http. What setting is causing this?

Jeremy's picture

Sounds like you've got a redirect somewhere...

Was it doing that prior to adding your SSL cert? By default TKL appliances should allow either HTTP or HTTPS (with self signed cert) OOTB. So unless you've added that prior and forgotten about it, nothing you've done should've changed it (assuming you follwed those directions).

Anyway, to resolve the issue check your virtual host settings (check in /etc/apache2/sites-enabled to see what's enabled and edit the file(s) in /etc/apache2/sites-available). If you find nothing there have a look for .htaccess files in your doc root (/var/www by default in LAMP appliance).

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)