TurnKey Linux Virtual Appliance Library

Very slow **Local** DNS updates when Stopping/Starting AWS Server

I am having issues with changing the instance type of my AWS servers that are hosted through Amazon/Turnkey. I've been experimenting with instance types for a particular application... and have a few times changed it from small to medium or visa versa through the Amazon AWS control panel.

My problem is that when I do this, the IP of the AWS server changes, and the Dynamic DNS gets knocked out. Further confusing the matter is that I've figured out that it's only my local DNS that's experiencing this issue. If I try using  a proxy site (hidemyass.com is my go-to), the Dynamic DNS URL works fine.

I'm using Windows 7, and no matter how many times I run "ipconfig /flushdns" nothing changes. All computers in my office are currently resolving my Dynamic URL to the wrong IP.

I tried logging into one of my other Amazon AWS servers, and when I ping the dynamic URL it DOES resolve to the right domain.

This has become a problem, because one of our customers experienced a day outage of service while we waited for DNS settings to propigate after I changed a server instance type on a Sunday evening.

What can I do to get the right DNS settings on my local computer, and more importantly... what can I do to ensure that if/when I need to change an instance type again that the DNS changes propigate as quickly as possible.

I've been doing ipconfig

I've been doing ipconfig /dnsflush all day and I still can't get this local DNS information to change. One very interesting thing I found by running ipconfig /displaydns is that for whatever reason, my local DNS has our dynamic DNS subdomain pointing at tklapp.com using a CNAME record, whereas another server we have a Dynamic DNS name for is pointing at the proper IP using an A (Host) Record.

I went to disassociate the dynamic DNS address from our server via the "User Profile" tab of the Turnkey Hub... but the ip associated with that domain name is correct on this page.

Again, the really frustrating part of all this is that my local DNS settings seem to be what's causing problems. Elsewhere on the internet, traffic is flowing to the right servers... but I can't configure some debugging compnents I have here locally until the domain resolves properly for me.

Lastly, I appologise for the double post. I got an error about some page hash not being valid, and after I reloaded the page and clicked submit two posts had been created. There is no way for me to delete the other!

Jeremy's picture

DNS caching for too long

If you have a local DNS server then you can reduce the time that DNS records are cached for and that will help (or perhaps your Modem/Gateway?). Flushing the DNS (and the problem remaining) should eliminate the possibility of it being your local computer.

Otherwise it may be your ISPs DNS service. It's a fairly common problem in my experience as ISP often seem to set their DNS to cache for a fairly long time (I guess to reduce server load and traffic). The only way around it (that I know of) is to use a 'better' DNS service. I have found Google's public DNS to be good (8.8.8.8 and 8.8.4.4).

Ah, I was just going through this with my linux desktop

I have been on the hub for a few weeks learning about cloud compting and testing my back up options. I've had the same thing going on right now. I just did a restore and I cannot get to my site domain name from my local computer Linux Ubuntu 12.04 Desktop and I am using google primary & secondary DNS.

I did have set in my connection my isp's DNS servers after my primary and secondary, becasue I could, and I find that when I removed the isp's dns everything came back for me.

I suggest that if you can get to your gateway and change your dns over to the google dns even just for a day or so it would fix your problem.

  I have changed my local DNS

 

I have changed my local DNS to google's... and I'm still having a problem with this.

I didn't stop / modify instance type / start an instance like last time, all I did was restart an instance through the turnkey hub interface. The IP of the server changed, and now the dynamic domain is STILL pointing to tklapp.com

Why would the *.tklapp.com domains EVER just point to the root tklapp.com domain? Is this an intermediary step before the domain changes over to the new IP when it does change?

Again, external proxy servers are pointing to the right site. Even when I'm using google's DNS servers... I can't get my local DNS to update and I'm stuck using the server's IP to access it. I am now terrified of having to restart our client's servers because it's going to create changes to the server's IP and thus cause DNS propigation issues.

I really, really need to get to the bottom of this. The biggest problem I see is that at some point, the dynamic DNS is getting a CNAME record pointing to tklapp.com instead of an A (Host) record pointing to the server's IP.

Jeremy's picture

All seems very strange...

I'm no expert when it comes to DNS so I'm out of ideas really. Seems like something is getting cached somewhere and for some reason the cache is living longer than it should.

The best way to go is to probably get elastic IPs for all your client machines. That way the public IP shouldn't change.

But on the other hand, why do you need to reboot anyway? I know I do it sometimes because I'm lazy, but really the only reason you should need to reboot is if you upgrade the kernel. Other operations/updates should only require restarting services (this isn't Windows remember! :D).

Chris Musty's picture

AWS IP's

If you are going to use AWS for hosting in a production environment ALWAYS contact AWS and get them to set your IP to static. The form is HERE (its also used for requesting email limit removal).

I repeatedly backup and restore servers when something happens (hacking, me messing up, something wiered happens) and I have never had an issue so long as I do the above.

If you dont, even when you stop your server it will get a new IP. If you have an elastic IP that they set to static it all just works. Also I just use the Hub rather than AWS' interface.

Chris Musty

Director

Specialised Technologies

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)