TurnKey Linux Virtual Appliance Library

No answer from port 80 or 443 after restore from Amazon to private

Subject says it all. I restored a medium machine from Amazon cloud back to the private hardware. After which Wordpress-appliance only replies to the local IP-requests. All other ports than 80 and 443 work fine. External firewall is unchanged from a configuration before moving the server to the amazon - it's fine.

I just cant find why Apache/Wordpress is no longer responding to the public IP at ports 80 or 443.

Jeremy's picture

Port forwarding?

Are yourt external requests being forwarded to your appliance? Perhaps you need to configure port forwarding. If you can ping sites on the internet from your appliance and your appliance responds to local requests (ie WordPress works ok from within the LAN) then that'd be my guess.

The only other thing that occurs to me is if Apache is setup to only respond to a domain name. Check the current Apache site(s) to make sure they are configured either to with wildcards or specific IP (or relevant domain name).

Chris Musty's picture

Been there Pulled hair over that

You need to modify WP files and the DB to change the site url. A good guide is here.

A simple test is to see if you can go to phpmyadmin. If that works from your local LAN (ie your not messing around with NAT) it will be the site URL for sure.

I have toyed with the idea of making a site migration script to help with this but have zero time to get into it.

Chris Musty

Director

Specialised Technologies

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)