TurnKey Linux Virtual Appliance Library

AjaXplorer first connection

Greetings,

I installed Turnkey File Server and I need to parameter file length to download. (Error "file too big")

I discovered I don't have admin rights with root user : I can't modify rights on users.

Documentation said to use login admin and password admin to connect first time but it don't work neither samba or local.

Is someone can help me ?

Regards,

Sebastien133.

Ric Moore's picture

First thing to try

Open a console for your container and enter "turnkey-init" and go through the paces. Good thing to update and upgrade when the opportunity presents itsel during the processf. Once done, exit the terminal. On your browser front end tool, stop and restart your container. Login again after the dust settles, so give it several minutes to shake out. Log back in as admin using your admin password and you should have control of everything.

 

I figured some response from what little I know, might help. :) Ric


Thanks !!! But it don't work...

Thanks a lot for your answer.

I tried but I can't administrate AjaXplorer. I can connect only with root user but I don't have administration access...

Regards,

Sebastien133.


Jeremy's picture

You need to adjust php.ini

The max filesize you can upload is limited by php, not AjaxExplorer (see 8.2 here). As noted in that FAQ, to increase the max size of upload you need to adjust the upload_max_filesize in php.ini (see here). OOTOMH you should find the php.ini file in /etc/php5/apache/php.ini. Personally I think the easiest way to do it is access the filesystem of your appliance via SFTP (using a client such as Filezilla - username:root password:<whatever you set>) then edit the file from there. Probably the best one to use if you are on Windows is Notepad++ (don't use normal Windows notepad for editing Linux files - it will break them).

IIRC AjaxExplorer runs under LigHTTPd so you'll proibably need to restart that:

service lighttpd restart

To clarify: To log in to Webmin, SSH, SFTP or the local console use the username 'root' and whatever password you set. To log into AjaxExplorer use the username 'admin' and whatever password you set. To access your Samba share (ie Windows shares) I would recommend that you create new Linux users and make sure that you remember to sync them with Samba users.

Samba Access

Thanks for the tip (admin vs root). I am having an issue where I can login with admin only, and cannot log in using any samba users that I have created (or even the root user which is a samba user as well). Is there something to check into to make that happen?

Jeremy's picture

AFAIK they use separate user databases

I vaguely recall reading somwhere (perhaps on the Ajaxplorer website?) how you could ulk add users but not sure whether it's possble to actually sync Samba/Linux users with Ajaxplorer...

Jeremy's picture

Looks like I was mistaken...

AjaXplorer canauthenticate against Samba users. Ni tsue on the details, but look here.

L. Arnold's picture

Likely FileServer needs to talk to Domain Server First

A few generations back I had FileServer connect to Domain Server (both TKL) and then they both floated on the domain for Windows Users.

I expect something of the same needs to happen here so that the Samba Logins can authenticate but there might be a way to set up those Users through Webmin directly.

I had to shut down v TKL 12 AjaXplorer last week as I couldn't get uploads to work...  fired up up V11 eXtplorer and it worked anyway (sorry for  a different subject).

Solution for Connection

Albiet a manual solution,

If you log in as the local admin and then add users that have the same username and password as thier unix / samba accounts, those users can then log in under the samba option as themselves and ajaxplorer will attach thier home folder and any other repositories that you have added that they also have access to.

Its pretty straight forward once you know, but does require knowing or having the user with you to enter in their passwords. Yes management will be a nightmare and I would be happy to find another more integrated solution, but at least this should get people going for now.

Cheers, Roy (Mindwire)

Manual Solution Didn't Work

Thanx for the suggestion, but it seems I did something wrong since it didn't work for me.

I created a user in AjaXplorer the same as one of my Samba/Unix users with the same password.

When I tried to Login using it in AjaXplorer it only allowed to connect as Local not Samba, and after connecting it didn't port the home folder or any of the shared folders of the user.

Any suggestions?

 

Regards

The file is too big

I am getting the 'The file is too big' error also.  I changed the upload_max_filesize variable in /etc/php5/cgi to 1024M. If I try to manually upload a file form ajaXplorer, anc click Options, it displays a 2M file upload limit. I restarted lighttpd on the server also.

Any other advice for a noob? I'm in day two of testing :)

Jeremy's picture

Not sure why that doesn't work...

A quick google suggests that you have done all the right things, so not sure why you are having this experience. Assuming that Ajaxplorer is running under Lighttpd (which I'm pretty sure it does).

Yep, it is strange.  In my

Yep, it is strange.  In my PHP.ini file, the upload_max was never set to 2MB, so I don't know where it's grabbing that limit. I'll keep searching, but if anyone else can help, it would save me a lot of headache.

Thanks

File Size Limitations

I just installed the fileserver on a standalong box and am having the same max upload filesize problem. The AjaXplorer says the limit is 2M and give the 'file too big warning'. There are two php.ini files on the server,

 

/etc/php5/cgi/php.ini
/etc/php5/cli/php.ini
 
I set both to 1G along with increasing post and memory parameters and restarted the server but with no success. Any suggestions?

Thanks!

Never mind...

I studied the core configs -> common 'uploader' plugin options under settings inside Ajaxplorer and found a file size parameter that limits the file size from the interface. Max upload is stil limited by the php.ini file but gives the administrator a quick method of raising or lowering within that max limit.

Thanks!

Fresh install

During install of fileserver I answered the root and ajax pw questions ...so do I still need to run turnkey-init to get things squared up?

Also I can't find what dir needs to be changed and the command to make it writable in order to update AJexplorer?  I checked their site and the faq link above doesn't mention it. I'd imagine I'd have to set it back after upgrading it...correct?

Also to give users access from the web do I just port forward 12??? to the fileserver IP?

Currently reading the AJ site.  I need to move the data folder to /home/username/ajdata or /home/ajdata/user  It shouldn't be left under the web app dir structure for security.


Jeremy's picture

No

You only need to run turnkey-init on systems that don't allow the auto run of firstboot scripts (eg Proxmox/OVZ).

My assumption is that Ajaxplorer is installed to the default webroot (/var/www) but I'm not 100% sure about that.

I would expect that Ajaxplorer runs from default http/https ports (ie 80/443 respectively) so forwarding them should work. Unless you are trying to forward ports so users can access Samba/SMB (ie Windows) shares. You'll need to check google if that's what you are trying to do...

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)