TurnKey Linux Virtual Appliance Library

ejabberd loses mod_shared_roster after reboot

I installed ejabberd from iso, and in the configuration found there was no entry for the mod_shared_roster in the 'Modules at ejabberd@localhost' section.

There is the ability to add this manually at the bottom, and I did this. The mod was working great and all users can see the shared roster, but after a reboot, the configuration for the mod is missing along with the shared roster.

Any ideas on how to make this persistent?

Thanks!

-Schwach

Hi! I have the same problem.

Hi!

I have the same problem. Found any solution yet?

Cheers

Found the solution: the user

Found the solution: the user ejabberd did't have wright rights to /etc/ejabberd

You can either activate the module in /etc/ejabberd/ejabberd.cfg or change the folder rights to 730.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)