TurnKey Linux Virtual Appliance Library

Webmin SSL not working

I cannot access Webmin via SSL.

I want to point out I did not install this turnkey linux setup or webmin.  If I make ssl=1 into ssl=0 in the /etc/webmin/miniserv.conf file I can connect and login to webmin via http.  However, I really need this to work over https.

This is the error I get in IE:

Internet Explorer cannot display the webpage.

In Firefox:

The connection was reset.

In Chrome:

This webpage is not available.

I have confirmed that port=12321 and listen=12321 in /etc/webmin/miniserv.conf as well.

Any ideas on what could be wrong?

 

It appears it may not be listening properly.

netstat -lp --inet shows :

Active Internet connections (only servers)

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name

tcp        0      0 localhost:mysql         *:*                     LISTEN      1328/mysqld    

tcp        0      0 *:ssh                   *:*                     LISTEN      1357/sshd      

tcp        0      0 localhost:smtp          *:*                     LISTEN      1487/master    

tcp        0      0 *:12321                 *:*                     LISTEN      2330/perl      

udp        0      0 subdomain.domain:ntp *:*                                 1164/ntpd      

udp        0      0 localhost:ntp           *:*                                 1164/ntpd      

udp        0      0 *:ntp                   *:*                                 1164/ntpd      

udp        0      0 *:12321                 *:*                                 2330/perl      

 

 

 

Same problem.. latest Turnkey Core, installed on laptop

same problem.. any solution?

I have the same issue also.

Any pointers would be appreciated.

Jeremy's picture

Assuming that you are all running Windows...!?

I suggest that you check your 'Internet Settings'. IIRC if you have your IE/Windows Internet Security Settings on 'High' then only https sites with CA signed certs are allowed by default (and by default all other web browsers will comply with IE/Win settings).

I also recall at one point I had a similar problem (although it wasn't on all browsers - IIRC it was only Firefox) that I had accidentally clicked a button which blocked the site (following the self-signed cert warning). I had to remove the black-listing of my server. I suspect that isn't your issue but thought I'd mention it just in case...

One other thing that I have experienced is another similar problem I had (although again not on all browsers, this time it was Chrome and it wasn't even TKL server but my Proxmox Server although similar thing...). I was getting the "This webpage is not available" error but it worker fine via Firefox. SImply cleaning the browser cache resolved that one...

Also obile, I note you say that it looks like it's not "listening properly". Why do you say that? Perhaps I'm missing something but it looks ok to me... namely:

tcp        0      0 *:12321                 *:*                     LISTEN      2330/perl
...
udp        0      0 *:12321                 *:*                                 2330/perl

Webmin is a Perl app and should be listening on 12321 and it appears to be identical to a working server that I have handy (except for the Perl PID obviously):

tcp        0      0 *:12321                 *:*                     LISTEN      774/perl
...
udp        0      0 *:12321                 *:*                                 774/perl

Server is TKL and browser running on Windows

Thanks for the relpy JedMeister. I appreciate the help.

In the end it was simpler than that. The IP address I had assigned was being used by another device. All working now.

 

 

 

 

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)