TurnKey Linux Virtual Appliance Library

TKLBAM backups stop working

I've checked out this thread: http://www.turnkeylinux.org/forum/support/20110128/easy-way-update-latest-vm

 

And added / check the firewall and still stuck at a dead end. The backups did work on this server for a while and just stopped randomly after a month.

 

I am getingthe issue with ntpdate from the post above.

 

Can anyone provide any insight to this?

Update

Just wanted to update after digging around more.

 

For some reason I'm not able to use ntpdate -u pool.ntp.org which the tklbam-backup uses. 

I am able to ntpdate -u 0.pool.ntp.org or 1..2... etc even specific hostnames inside the pool. Is there anyway I can edit the backup script to use a different pool than "pool.ntp.org" ?

Jeremy's picture

A few thoughts...

I doubt that the NTP server is hardcoded into TKLBAM. I imagine that it uses whatever NTP server that the server itself is set to use. So I'd try adjusting that. I don't know for sure but I would expect a config file in /etc - or maybe you can/need to reconfigure it with dpkg - something like 'dpkg-reconfigure ntp'...?

Failing that, perhaps not the best solution - but another fairly easy way to go would be to just add an entry to the /etc/hosts file to redirect the ntp lookup to what ever server you want.

Thanks for the update

Thanks for replying. I'm not too sure what the issue is, but when i run the backup it shows ntpdate -u pool.ntp.org. Either way we have about 7 turnkey linux servers and this is the only one suffering with this issue. I just mapped an entry in the host file for a temporary fix. I'll check more into configuring ntp again.

 

Thanks again Jeremy!

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)