TurnKey Linux Virtual Appliance Library
Jeremy's picture

In a word yes!

But you will need to get your hands dirty...

Also note that the instructions given are quite generic and so this will involve some googling on your part. Also keep in mind that TKL v12.0 is based on Debian 6 aka Squeeze and that Debian package Apache a little differently to other distros (and the way Apache docs themselves describe the setup).

A couple of things off the top of my head:

  • Use the /etc/apache2/ports.conf to configure the ports that Apache listens on
  • Create a new virtual host file in /etc/apache2/sites-available and then disable the default and enable your new one like this:
a2dissite default
a2ensite new-site-name
  • IIRC the main Apache config file in Debian/Ubuntu is /etc/apache2/apache2.conf
  • Restart Apache (whenever config is changed) with:
service apache2 restart
  • If you have any issues look for apache logs in /var/log

Gonna Try

Thanks Jeremy.  I am going to try all that you have said even though I am not an expert at this :).  Hopefully I can get somemore info if it doesn't work.  I will post an update soon.


Jeremy's picture

No worries.

I wasn't either when I started with TKL a few year back, but I've learned a lot! And nothing helps you learn better than doing (IMO). Google is possibly one of the best Linux resources I think.

Good luck! :)

Cannot Remote Access LAMP webserver

Ok. So I have set up access to my home camera based on the instructions from the website and some help from Jeremy.  The only thing I didn't do is disable the default site and enable the new one as instructed. Instead I created the additional site by modifying the file through LAMP interface.  When I test it locally everything works. I am able to not only access the LAMP server but also access my Home Camera through HTTPS.  I then tested it on my blackberry by disabling its wifi and successfully connected to the external address of my site.

However, whenever I try to access the server from work or if I ask various persons to try to access it, it does not connect and it times out.  I have even gone as far as disabling my AVG firewall to see if this was the problem. 

What am I doing wrong?


Jeremy's picture

A few thoughts...

My first is NAT/port forwarding config - most consumer modem/routers include NAT which require port forwarding to access internal servers (on your home network). However as you said that you could access it via the internet (with wifi off) on your Blackberry that seems unlikely.

The next is dynamic IP. Most home internet plans have a dynamic IP (ie it changes occasionally). So unless you specifically have a static IP, using IP address to contact your server remotely isn't going to be reliable. You'd be better off setting up some sort of dynamic DNS ie have a domain name which maps to your external IP, with a program running which updates on a regular schedule. TKL Hub supplies this service free or there are plenty of other free and paid 3rd party services.

There's plenty of other possible reasons too relating to the networking setups where you are trying to connect from.

Works!!

I left it for the night and decided to ask my friends to test it again.  It works!!! Seems like it needed some time to propogate or something.  The only thing is that it is slow. Thanks for the help though.


seo

I just came onto your post and found it quite interesting. I am also associated with IP Camera Software, Ruckus Wireless and enjoy  to read the stuff on the same as its rarely found on internet. Thanks again for writing such a good post.

IP camera

thanks for  this info. it reall helps me, i will try this. 

IP camera

thanks for  this info. it reall helps me, i will try this to my <a href = "http://dpointtechnologies.com"> IP camera </a>

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)