TurnKey Linux Virtual Appliance Library

Virtual Hosts working on a local machine; not working after deployed to the Hub

 

Bear with me; while I'm somewhat experienced with Windows, this is my first meaningful attempt at getting a Linux server online.  My goal is to move two sites that are running WordPress and CiviCRM under Acquia Drupal on Windows to a Turnkey LAMP-WordPress-CiviCRM machine on TK Hub.
 
I downloaded the LAMP VM to my Mac and let it configure itself using DHCP. I set up two virtual domains on it and installed two instances of WordPress and CiviCRM.  I added the two domains to my local hosts file, and was able to access both without any problems, everything displayed fine, was even successful in migrating my data over.  Complete success when running as a virtual machine.
 
From there I created a TK Backup account and successfully backed up my VM to it.
 
I then created a TK Hub account and server, assigned an Elastic IP to it, and restored from the backup.  I edited the DNS settings at GoDaddy to point to the elastic IP address.
 
The problem is that now when I go to each domain name, it's displaying the Turnkey LAMP screen with the three control panel-style links - not the proper WordPress installations that were available when the install was on my local machine.
 
Are there any additional steps required once the machine is restored to Amazon's servers to make these publicly accessible?  I'm at a loss here.

I should mention the

I should mention the configuration method I used is JedMeister's instructions at the bottom of this page:

http://www.turnkeylinux.org/forum/support/20111129/lamp-virtualhost-name...

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)