TurnKey Linux Virtual Appliance Library

Need some help

 

Folks I have no clue about this one. I have Turnkey Wordpress installed on an ESXi host. All was going fine and I created quite a bit of content - testing the site as I went along. Now, coming back a day later the site does not display. Rather, I see an "Index of" empty directory listing. I can still get to wp-admin as normal. There were no changes except content via wp-admin. I've ssh'd to the box and the page directory is still intact and all looks fine. Very odd. I'm thinking somehow some permissions got mashed. But, maybe no. And, I'm not sure what to check.

Any help greatly appreciated.

David R (frustrated)

A few things to try

Hi David,

 

I develop Joomla sites, so it's a bit similiar CMS to Word Press. There are quite a few links in the chain that can go wrong.

If you create a simple index.html file and upload it to your web server (put it in the same directory as your wordpress index.php) and see if you can access it. 

...edit... re-read your post and wonder, do you have an index.php page in your wp-content?

If you're getting a index of, it would seem you don't have an index.php page to serve. Make sure apache virtual server is pointed to the proper directory, too.

______________________ blelow is what I wrote before I realized it might just be the index.php page_____________

If you can, then your apache server is functioning properly for that directory. (my guess is that it is, b/c you can get to your admin page, but techincally that is a different directory

 

If you can't access the index.html, then I would start looking at directory and file permissions.

I would also look at your settings in your wordpress admin, and see if by chance something got accidently clicked? (I'm not super familiar with WP, but in Joomla turning on SEF/SEO url's can break the index.php or installing a new extension that isn't properly config'd)

Next, I would look at your .htaccess file and compare it to a default .htaccess for WP and see if anyting is foobar'd in there http://wordpress.org/support/topic/i-destroyed-my-site-default-htaccess

 

OH! and you probably already know this, but force a refresh on your browser. I can't tell you how many times browser caching has prevented me from seeing the page properly after I fixed it. 

 

Good luck!

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)