TurnKey Linux Virtual Appliance Library

TKBackup fails but reported as successful :(

Hi

Just realized that my TKBackup are failing, yet the webmine interface reports them are being successful (or at least don't report any error: Backup ID #1, Updated Sat 2013-01-12 06:41).

However there are issues with the backup:

(lot of log omitted)
<Error><Code>NotSignedUp</Code><Message>Your account is not signed up for the S3 service. You must sign up before you can use S3.</Message><RequestId>25464992BDC708DB</RequestId><HostId>gOBxjBV9NUdItTPy78h3qscV2jjPUBcmDKNQF9lILkkQM+Wd+zmyMAiR5StAY+H+</HostId></Error>)
Failed to create bucket (attempt #5) 'tklbam-z27qsisf3lg4gvz7' failed (reason: S3ResponseError: S3ResponseError: 403 Forbidden
<?xml version="1.0" encoding="UTF-8"?>
<Error><Code>NotSignedUp</Code><Message>Your account is not signed up for the S3 service. You must sign up before you can use S3.</Message><RequestId>0CB3BD77FC4D0A56</RequestId><HostId>c5Uw5SOJ+xn+Tj0AhKjmlPgICgqt+iwPMdD40tzD34E+IY5078Hv0/0rBme/3k2l</HostId></Error>)
Uploading s3://s3.amazonaws.com/tklbam-z27qsisf3lg4gvz7/duplicity-full.20130112T105402Z.manifest.gpg to STANDARD Storage

--------------[ Backup Statistics ]--------------
StartTime 1357988042.80 (Sat Jan 12 10:54:02 2013)
EndTime 1357990571.48 (Sat Jan 12 11:36:11 2013)
ElapsedTime 2528.69 (42 minutes 8.69 seconds)
SourceFiles 51109
SourceFileSize 516054200 (492 MB)
NewFiles 51109
NewFileSize 516054200 (492 MB)
DeletedFiles 0
ChangedFiles 0
ChangedFileSize 0 (0 bytes)
ChangedDeltaSize 0 (0 bytes)
DeltaEntries 51109
RawDeltaSize 472298683 (450 MB)
TotalDestinationSizeChange 183592950 (175 MB)
Errors 0 !!!!!
-------------------------------------------------

Not sure exactly what's going on with my S3 account (used to be working fine) but it is definitely not backing up :(

Any advices as of how to fix this ?

Regards

Jeremy's picture

Hmmm....

That doesn't seem right. Surely not being able to connect to S3 should give an error! (Obvioulsy it does, but only sort of...)

I recommend that you contact the core devs using the Hub Feedback feature (blue button on left hand side when logged into the Hub). That way they will be able to have a look and see what is going on with you Hub and/or AWS account.

Tried to contact dev through

Tried to contact dev through the feedback mechanism but have not heard back for 2 days now. Is this typical ? Any advice on investigating this one ?


Jeremy's picture

No they're usually pretty responsive to Hub Feedback

But I do know that they are very busy (deep in development - hopefully there will be an announcement soon about what they've been up to) and unless you are on the "Business Plan" there is no "guaranteed timely support". However I will try to get in touch with them (although I can't guarantee anything...)

In the meantime I'd doublecheck your Amazon account and make sure something hasn't gone wrong (eg perhaps you've got a new credit card and neglected to update the details). I'd log into both AWS and the TKL Hub and see what both of them say in that regard. I'm guessing you've already had a look at those, but could be worth a double check. Maybe it's something obvious that you inadvertantly over looked?

If you haven't heard anything in another day or 2 then please bump this thread again. Cheers.

I also have this problem and

I also have this problem and only just realised I haven't had a backup since last september! Did you get any further information?

 

cheers

OK. I've now found what the

OK. I've now found what the problem was.. Last september my credit card expired, and even though I updated AWS with the new details, Turnkey hub wanted me to re-order the S3 backup option with AWS, I only found this out as I had an old backup I tried to delete and thats when a message popped up saying S3 backup wasn't enabled! Turnkey.. please can you make a pop up on the dashboard when this happens? 

Jeremy's picture

I've lodged a bug report

Thanks for reporting and providing the extra feedback. See the bug report here.

And whilst I completely agree with you that there should be an error raised and some sort of notification, this again raises the point that important stuff like backups, aren't something that you can just trust to work without manually checking from time to time...

No matter how good the program, it was created by humans, and no matter how good the programmer, we are all fallible and sometimes things fall through the gaps...

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)