TurnKey Linux Virtual Appliance Library

Missing Passwords - Cannot login to MySQL, phpMyAdmin or SugarCRM

This web page (turnkeylinux.org/core) says:

> First boot initialization: Prompt user for passwords

... and this web page (turnkeylinux.org/sugarcrm) says:

> Credentials (passwords set at first boot):

... yet even though my host has twice installed the tar.gz version of your SugarCRM virtual appliance on my OpenVZ VPS he says he was never prompted for any passwords.

After my host's installation I was able to login via ssh and Webmin with my root password, but I have been unable to login to MySQL, phpMyAdmin or SugarCRM.

Apparently this OpenVZ appliance contains built-in default passwords that are undocumented, at least on the above web pages.  So can you please send me these pre-configured passwords?

Also please reconfirm that these usernames are correct, or send me the correct usernames:

> MySQL and phpMyAdmin: username=root

> SugarCRM: username=admin

Jeremy's picture

Need to run init scripts manually...

OVZ templates do not have a true console, therefore interactive scripts can not be triggered to run on first boot (they will just cause your VM to hang waiting for user input from a console that doesn't exist...) So as is documented in multiple places (such as the OVZ announcement blog post, multiple times in the VM notes in the docs/wiki, multiple forum posts, etc...) you need to run

turnkey-init

Thanks Jeremy.  The one place

Thanks Jeremy.  The one place this issue should be documented but is not is on this page ... because this is the page everyone will visit FIRST when they decide to use the SugarCRM appliance:

http://www.turnkeylinux.org/sugarcrm

Given the fact that adding a little bit of text to this page would be so simple and effective, it makes me wonder why no one has bothered to put something like this on the page before now:

Exception: The OpenVZ tarball will not prompt for passwords.  Instead it will set the ssh and Webmin passwords to the root password in your OpenVZ Control Panel.  MySQL, phpMyAdmin and SugarCRM passwords will be set to 'turnkey'. Use Webmin to change the MySQL password.  Use the command 'turnkey-init' to change the phpMyAdmin and SugarCRM passwords.


Jeremy's picture

It applies to all OVZ appliances though, not just SugarCRM

AFAIK it also applies to Xen and OpenStack builds as well. So whilst it may be relevant to point to the docs explaining the situation, it would involve updating all 100+ appliances pages. Bottom line is that you are right that something should appear on each appliance page (perhaps a link to documentation that explains it more fully) where it says "passwords set on first boot"...

Regardless (and no offense intended but) a google search of "turnkey linux ovz passwords" gives a number of results which explain the situation and the TKL internal search (top right on every page) for "ovz passwords" turns up similar results. So the info is out there (if not completely obvious at first glance).

A link to the correct login info would certainly be appropriate

I know the info is out there, that's how I found the solution to the problem before you replied to my original inquiry.  Thankfully your response confirmed the issue for me, and I appreciate it.

I agree, these pages need (at least) a link to the CORRECT login information for OpenVZ.  Maybe they should add a link to this forum thread?


I'm having this same trouble.

I'm having this same trouble. I can get into webmin, which then lets me into mysql.

But I'm not able to log into sugarcrm, and I have no idea where I'm supposed to run the

turnkey-init

command.

 

Help

Jeremy's picture

As of v12.1 you may not need to run it manually

But if you haven't set the password for SugarCRM then you are missing a step... See if this helps.

Post new comment

The content of this field is kept private and will not be shown publicly. If you have a Gravatar account, used to display your avatar.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <p> <span> <div> <h1> <h2> <h3> <h4> <h5> <h6> <img> <map> <area> <hr> <br> <br /> <ul> <ol> <li> <dl> <dt> <dd> <table> <tr> <td> <em> <b> <u> <i> <strong> <font> <del> <ins> <sub> <sup> <quote> <blockquote> <pre> <address> <code> <cite> <strike> <caption>

More information about formatting options

Leave this field empty. It's part of a security mechanism.
(Dear spammers: moderators are notified of all new posts. Spam is deleted immediately)