I find today that apt-get update no longer updates my Turnkey Drupal 6 VM: I'm now getting a NO_PUBKEY AED4B06F473041FA

Is this something I've done or perhaps a known issue?

Replies (5)

Maybe related to Debian changing their signing key

Reply 1

I think this may have something to do with the previous stable version of TurnKey Drupal 6 being pinned to Debian stable for security updates. Debian updated their archive key recently on Feb 9th, 2011.

What about upgrading to the latest stable?

Reply 2

Personally I'd suggest you use TKLBAM to migrate your data to the latest (v11.1) version.

OK, that looks like the reason...

Reply 3

Thanks, that looks like the reason. I'm still rather stuck though. Does anyone have a solution? I've tried adding debian-archive-keyring (failed) and then ubuntu-keyring (install success but apt-get update still fails).

Does anyone else have this issue with Turnkey Drupal 6?

I can confirm that this works

Reply 4
I ran into this issue on an older VM and can confirm that the above solution does in fact work, except for a typo in the command name which is gpg not pgp:
gpg --recv-key AED4B06F473041FA
gpg -a --export AED4B06F473041FA | apt-key add -

Yes, that was it I think!

Reply 5

Yes, thanks Liraz -- I don't remember exactly what fixed it but there was some messing around required with the new key.