Forum archive
How do I use TKL File Server as a VMWare Datastore?
I set up a dedicated server running TKL File Server with 2 x 2TB Sata drives. I want to use this server as a low-cost NAS.
I've set up samba to sync with users and have been able to connect to the drives in Windows.
My problem is I don't know how to use it as a datastore for my VMWare ESXi4 hosts. I have 2 storage locations already created for guests with RW for 2 users storage and storage2.
/srv/storage on sda1
/home2/storage2 on sdb1
when I df here is what it looks like:
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/turnkey-root
1.8T 1.3G 1.7T 1% /
none 496M 204K 496M 1% /dev
none 502M 0 502M 0% /dev/shm
none 502M 476K 501M 1% /var/run
none 502M 0 502M 0% /var/lock
none 502M 0 502M 0% /lib/init/rw
/dev/mapper/groupb-volumeb
1.8T 196M 1.7T 1% /home2
/dev/sda2 229M 18M 200M 8% /boot
root@fileserver ~# I am using vSphere Client Version 4.0.0 to manage the ESXi hosts
I have been able to connect my 1TB WD World Book this way so I know it can be done.
The ESXi host IP is 10.10.10.20 and the fileserver is 10.10.10.5
Here is the error I receive when I try to connect:
Create NAS datastore 10.10.10.20 Error during the configuration of the host: NFS Error : Unable to Mount filesystem: Unable to connect to NFS server mikebest66 VM002 5/11/2011 9:45:59 AM 5/11/2011 9:46:00 AM 5/11/2011 9:46:31 AM
My guess this is a permissions issue but I don't see how I can give the username and password to fileserver in vSphere when I try to connect the datastore.
Can I allow all IP's in the 10.10.0.0/8 range access on the file server?
Any help would be greatly appreciated.
AFAIK NFS is not setup by default in any of the TKL appliances. My guess is that that is the problem: