Forum archive
Login fails on first boot
I just installed the TK OTRS appliance in a CT on PVE. I am able to remote into it and login as root. I can alo use the same root credentials and logon to Webmin.
When trying to log into the OTRS administration with the user "admin" and the same password as root, the login is denied.
On the TK appliance info page, it says: "Credentials (passwords set at first boot)".
What am I missing?
Because OVZ containers don't have a true console the firstboot scripts can't run. (It was a problem I encountered when first building the OVZ templates prior to TKL officially supporting them). So rather than have them hang waiting for input (which you can never provide...) they run with default values in TKL OVZ templates.
So as a intermediate workaround (untill someone works out how to hack the PVE interface to allow you to preseed values from within the UI, as you can with the Hub) you need to run the first boot scripts manually when you first launch an appliance.
is the command you are looking for. So login via SSH (or whatever) and run that and you'll be good to go.
FYI, not that I mind answering your question but this is documented at least in a couple of places, like the OVZ build announcement and the Virtualization notes in the Docs (which I have just expanded a little). :)