Hi,

I'm trying to detach an EBS volume from one of my instances but this fails with message "Error in detach volume, auto attach task is running". The volume is not mounted anywhere and I have rebooted the instance but still I get the error. Any ideas?

Thanks,

Ian

Replies (4)

2 weeks, no progress...

Reply 1

...hence shameless bump. Can anyone help here?

Sorry for slow response...

Reply 2

My suggestion would be to contact the devs directly via the Hub feedback (blue button on the left when logged in).

Well it is... But it's also a direct line to the devs

Reply 3

And because the notification the devs get includes your Hub account they know exactly where to start looking.

Anyway, glad you got it sorted and good to know that there is a workaround.

AFAIK the auto-attach is a backend Hub script. It can probably be triggered by the Hub API but I haven't checked (have a look in the docs if you're keen).

Ah, I thought that was just

Reply 4

Ah, I thought that was just some feedback thing!

Anyways, I was still getting the error via the hub dashboard and couldn't see a way of detaching/deleting it direct from the AWS dashboard, yet, bizarrely, the AWS plugin for Eclipse allowed me to to do both and this was immediately reflected in the hub!

I'd still be interested to know what this auto attach thing was and whether it could be configured?

Thanks all the same.