result is 404

Replies (4)

Cause of PAM Authentication Error

Reply 1

I've discovered that the root cause of the PAM authenticatin error is that the Jenkins plugins are not loading (including the PAM plugin)

The reason they are not loading is due to filesystem permissions.  The plugin directory is owned by root instead of being owned by jenkins.

To fix it:

  1. log-in or ssh to the server as root
  2. cd to /var/lib/jenkins
  3. execute: chown jenkins:nogroup plugins
  4. Restart jenkins (or reboot the server)

You should now be able to log-in as admin with the password that was set at first boot.

You should still be able to use it

Reply 3

It's just that you'll need to log in via SSH (or SFTP or Webmin) and make the required changes as per the workaround above.

The only note is that you may need to adjust permissions (assuming that you use the root account to edit the files). Perhaps check their permissions prior to anything else!? ('ls -la /path/to/files') then chmod/chown them as appropriate...

Want to confirm that this is

Reply 4

Want to confirm that this is the case after launching a jenkins 12.1 appliance. Provided administrator user and password fail to login and making the jenkins appliance not useable from the hub.