Forum archive
Tklbam backup fails after EBS change
Hello there guys,
I have this instance running on EC2. It is a Nginx + Varnish + Mysql + PHP5-FPM, build precisely for my needs using Turnkey core as base.
Turns out I had to increase EBS volume size and that is only possible by the snapshot + create new ebs from snapshot. So I created a new ebs with tripe the size, detached the old ebs volume and attached the new one.
Tklbam backup does not work anymore.
Traceback (most recent call last):
File "/usr/bin/tklbam", line 46, in <module>
CliWrapper.main()
File "/usr/lib/tklbam/cliwrapper.py", line 88, in main
commands[command].main()
File "/usr/lib/tklbam/cmd_backup.py", line 385, in main
if not opt_simulate and not opt_disable_resume and registry.backup_resume_conf == conf:
File "/usr/lib/tklbam/registry.py", line 212, in backup_resume_conf
return BackupSessionConf(simplejson.loads(s))
File "/usr/lib/python2.7/dist-packages/simplejson/__init__.py", line 451, in loads
return _default_decoder.decode(s)
File "/usr/lib/python2.7/dist-packages/simplejson/decoder.py", line 402, in decode
obj, end = self.raw_decode(s, idx=_w(s, 0).end())
File "/usr/lib/python2.7/dist-packages/simplejson/decoder.py", line 420, in raw_decode
raise JSONDecodeError("No JSON object could be decoded", s, idx)
simplejson.decoder.JSONDecodeError: No JSON object could be decoded: line 1 column 0 (char 0)
Any suggestions of anything I could try before having to rebuild the whole thing?
Any help is welcome.
Best regards.
TBH I have no idea what might be up for you. If you have a very recent TKLBAM backup then you could try restoring that to a new instance (that has the desired size EBS)... I think that should work...
Regardless I have lodged a bug on the TKL Issue Tracker.