Forum archive
Cannot get turnkey-init working for any appliance on proxmox
I have been running proxmox ve with KVM for a while now. Decided recently to give TKL a go within proxmox, and it has been a bad experience so far.
The containers install OK (but show errors where one would expect the initialization scripts would have been run) .. after proxmox CT install, system boots into a console CLI prompt, where I am able to login.
All attempts (via proxmox 'vzctl enter' OR via the web console OR via an ssh session direct on the appliance) to initialize the container fails with similar error messages as below ..
- Proxmox VE 3.1-45
- I have tried the following appliances: jenkins, sugarcrm, zurmo, vtiger, canvas (all version 13.1, x64 .. except vtiger which is 12.1)
- As can be seen below, it complains about the nat module of iptables
- Errors seem to suggest python-tk is missing (and indeed dpkg shows its not installed)
- I installed (via apt-get) python-tk and apt-utils, but I am still unable to run a successful turnkey-init
- Anyone able to point me to how I can attempt to resolve this problem?
- Is there a way to get the appliances configured without using turnkey-init?
The error messages is attached as a text file, because your system kept flagging it as spam when I tried to paste it here ..
I have been using TKL appliances on PVE since v1.9 and for me the v13.0 appliances are the smoothest experience yet...
Usually i create the container via the Web UI and then login via SSH once the container has been created. Since version v13.0, manually running turnkey-init is not required (it auto runs on first login).
My first guess is that the downloads are corrupt but I am only guessing... I just retested the v13.0 (x64) Canvas appliance on my PVE v3.1 home server and it starts and the init hooks run fine. For what it is worth here is a copy of the terminal:
Then it went to the usual init screens where you enter passwords etc. Finishing with: