Sorry for all the questions...

When I try to view either the storefront or backend of my Turnkey EC2 Magento instance (started via the hub, I get an error saying "

There has been an error processing your request

Exception printing is disabled by default for security reasons.

Error log record number: 1272041266384"

Is anyone able to advise, please?

Regards

Hugh

Replies (4)

Hmmm not sure...

Reply 1
It should just work out of the box. I'm not super familiar with Magento so I'm not sure what might cause that. Have you changed anything or is this still a clean install?

I don't know if Magento keeps it's own log? If so that'd be worth a look. Otherwise (or as well as) have a look at /var/log/apache2/error.log

We have a Magento user who frequents the forums but haven't seen him for a while...

I have done some more investigating

Reply 2
I have done some more investigating and an Amazon there seems to be an intermittent issue with the initialisation hooks that TurnKey runs on firstboot.

Whilst I haven't been able to reproduce your initial issues (root password) I did reproduce this one. However if I log in via SSH as root and rerun the firstboot initialisation scripts (aka inithooks) then it all works as it should. Investigating the broken install; there is no error regarding inithook failure that I could find being logged anywhere. The fact that it works when manually invoked demonstrates that the inithooks themselves are ok. I suspect that there is a race condition somewhere that is only occurring under a specific set of (as yet unknown) circumstance. FWIW I cannot reproduce this anywhere other than on Amazon (i.e. if I download the ISO and install on a VM the inithooks work automatically and Magento works fine OOTB...)

FWIW the whole inithooks sequence can be re-run like this

turnkey-init

Or the Magento specific one on it's own:

/usr/lib/inithooks/bin/magento.py

There's definitely an issue.

Reply 3

There's definitely an issue.  I destroyed the server and set a new one up, standard settings, haven't changed anything, and the new one has exactly the same problem.

Thanks Jeremy.

Reply 4

Appreciate your help.