Forum archive
Let's Encrypt basic question for cert generation
Thanks to TKL for simplifying the rather complicated setup of SSL on webservers. I'm running V15.3 of the TKL Wordpress Appliance ISO: turnkey-wordpress-15.3-stretch-amd64.iso
I read this doc on the Let's Encryption procedure:
And I noted this warning:
"Note: Please ensure that you have your Domain nameservers correctly configured prior to running this. Failure to do so will cause the Let's Encrypt challenges to fail (so you won't get a certificate). Repeated failures may cause your server to be blocked (for a week) from further attempts."
I bolded the phrase that has me a bit worried: Domain nameservers correctly configured
Could someone expand on what "correctly configured" means?
Currently, my domain has been purchased.
Browsing to www.mydomain.com redirects me to a free instance of Wordpress on their Wordpress.com site.
And I've configured email forwarding such that emails sent to the domain are forwarded to my Gmail account.
Is this "enough of a correct configuration "for me to get my Let's Encrypt Certificate?
If not, what else do I need?
I noted that in a document relating to installing Let's Encrypt from Owncloud.com [https://doc.owncloud.com/server/admin_manual/installation/letsencrypt/using_letsencrypt.html], they said:
"Requirements & Dependencies
You require a domain name with a valid A-Record pointing back to your servers IP address. In case your server is behind a firewall, take the necessary measures to ensure that your server is accessible, worldwide, from the internet, by adding the required firewall and port forward rules."
At this moment, mydomain.com points to my Wordpress.com site. For the certificate generation, do I need to change it to point to the IP of my firewall at home? My future website and its WP appliance is behind my home firewall (this is the WP appliance that I want the SSL cert for).
Related to the Owncloud statement, I can port forward 80 on my home firewall to the WP appliance. Is this good enough?
Great suggestion! I've just added an issue to the tracker so this doesn't get forgotten...